summaryrefslogtreecommitdiffstats
path: root/python/pep8
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-05-03 15:31:32 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-05-03 15:31:32 -0500
commitc63dbc22c3a341245f950f1f27447de6f913295f (patch)
treea54bb5577975c1d8e160d06cd6b4a8c71fe5eb9b /python/pep8
parentaf5062470253b9afae7071c3cb8eab4f1e2c9c9b (diff)
downloadslackbuilds-c63dbc22c3a341245f950f1f27447de6f913295f.tar.gz
slackbuilds-c63dbc22c3a341245f950f1f27447de6f913295f.tar.xz
python/pep8: Moved from Development category
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/pep8')
-rw-r--r--python/pep8/LICENSE.txt21
-rw-r--r--python/pep8/README4
-rw-r--r--python/pep8/pep8.SlackBuild50
-rw-r--r--python/pep8/pep8.info10
-rw-r--r--python/pep8/slack-desc19
5 files changed, 104 insertions, 0 deletions
diff --git a/python/pep8/LICENSE.txt b/python/pep8/LICENSE.txt
new file mode 100644
index 0000000000..c4610a9f6d
--- /dev/null
+++ b/python/pep8/LICENSE.txt
@@ -0,0 +1,21 @@
+Copyright (C) 2006 Johann C. Rocholl <johann@rocholl.net>
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation files
+(the "Software"), to deal in the Software without restriction,
+including without limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of the Software,
+and to permit persons to whom the Software is furnished to do so,
+subject to the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/python/pep8/README b/python/pep8/README
new file mode 100644
index 0000000000..a169dbd683
--- /dev/null
+++ b/python/pep8/README
@@ -0,0 +1,4 @@
+pep8 is a tool to check your Python code against some of the style
+conventions in PEP 8 <http://www.python.org/dev/peps/pep-0008/>.
+
+This requires pysetuptools.
diff --git a/python/pep8/pep8.SlackBuild b/python/pep8/pep8.SlackBuild
new file mode 100644
index 0000000000..a3ba6a6b29
--- /dev/null
+++ b/python/pep8/pep8.SlackBuild
@@ -0,0 +1,50 @@
+#!/bin/sh
+
+# Slackware build script for pep8
+# Written by Audrius Kažukauskas <audrius@neutrino.lt>
+
+PRGNAM=pep8
+VERSION=${VERSION:-0.6.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/LICENSE.txt > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE.txt
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pep8/pep8.info b/python/pep8/pep8.info
new file mode 100644
index 0000000000..fbd2906d6f
--- /dev/null
+++ b/python/pep8/pep8.info
@@ -0,0 +1,10 @@
+PRGNAM="pep8"
+VERSION="0.6.1"
+HOMEPAGE="http://pypi.python.org/pypi/pep8"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pep8/pep8-0.6.1.tar.gz"
+MD5SUM="49380cdf6ba2e222e8630cb0afe29d66"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Audrius Kažukauskas"
+EMAIL="audrius@neutrino.lt"
+APPROVED="Niels Horn"
diff --git a/python/pep8/slack-desc b/python/pep8/slack-desc
new file mode 100644
index 0000000000..016ed3f89e
--- /dev/null
+++ b/python/pep8/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pep8: pep8 (Check Python source code formatting)
+pep8:
+pep8: pep8 is a tool to check your Python code against some of the style
+pep8: conventions in PEP 8 <http://www.python.org/dev/peps/pep-0008/>.
+pep8:
+pep8: Homepage: http://pypi.python.org/pypi/pep8
+pep8:
+pep8:
+pep8:
+pep8:
+pep8: