summaryrefslogtreecommitdiffstats
path: root/python/psutil/psutil.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2020-01-26 11:47:36 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-02-01 09:00:35 +0700
commitff746b390580c04fb9b8b63220e943fbed05155f (patch)
tree4dde3395cef8e3f4034e53852b6b979046821620 /python/psutil/psutil.SlackBuild
parent13b54ae90c9a4cf35716b193c6f5294fe94e7328 (diff)
downloadslackbuilds-ff746b390580c04fb9b8b63220e943fbed05155f.tar.gz
slackbuilds-ff746b390580c04fb9b8b63220e943fbed05155f.tar.xz
python/psutil: Updated for version 5.6.7
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'python/psutil/psutil.SlackBuild')
-rwxr-xr-x[-rw-r--r--]python/psutil/psutil.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/psutil/psutil.SlackBuild b/python/psutil/psutil.SlackBuild
index c37311562e..7432bbecb2 100644..100755
--- a/python/psutil/psutil.SlackBuild
+++ b/python/psutil/psutil.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for psutil
-# Copyright 2012-2019 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psutil
-VERSION=${VERSION:-5.6.3}
+VERSION=${VERSION:-5.6.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,8 +57,8 @@ find -L . \
python setup.py install --root=$PKG
-# Install python3 bindings for psutil. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
+# Install python3 bindings for psutil.
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi