summaryrefslogtreecommitdiffstats
path: root/python/pycodestyle
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-11-05 05:24:41 +0200
committer David Spencer <idlemoor@slackbuilds.org>2016-11-11 20:36:30 +0000
commit4f1b9ce3170cf7dc476ccebefdb76bb2d92ced0c (patch)
treeb7a5616444f65804206867249c809015acb0d6b6 /python/pycodestyle
parent5dee216c0d6f34497411c22f482a3b0042e683d5 (diff)
downloadslackbuilds-4f1b9ce3170cf7dc476ccebefdb76bb2d92ced0c.tar.gz
slackbuilds-4f1b9ce3170cf7dc476ccebefdb76bb2d92ced0c.tar.xz
python/pycodestyle: Updated for version 2.1.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/pycodestyle')
-rw-r--r--python/pycodestyle/pycodestyle.SlackBuild12
-rw-r--r--python/pycodestyle/pycodestyle.info6
2 files changed, 7 insertions, 11 deletions
diff --git a/python/pycodestyle/pycodestyle.SlackBuild b/python/pycodestyle/pycodestyle.SlackBuild
index 17d374742a..8955e1a998 100644
--- a/python/pycodestyle/pycodestyle.SlackBuild
+++ b/python/pycodestyle/pycodestyle.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pycodestyle
-VERSION=${VERSION:-2.0.0}
+VERSION=${VERSION:-2.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -69,10 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Fix permissions for docs and python egg-info folder
-chmod 0755 -R docs $PRGNAM.egg-info
-
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/pycodestyle/pycodestyle.info b/python/pycodestyle/pycodestyle.info
index 983fcfaf29..f255042499 100644
--- a/python/pycodestyle/pycodestyle.info
+++ b/python/pycodestyle/pycodestyle.info
@@ -1,8 +1,8 @@
PRGNAM="pycodestyle"
-VERSION="2.0.0"
+VERSION="2.1.0"
HOMEPAGE="https://pycodestyle.readthedocs.io/en/latest/"
-DOWNLOAD="https://pypi.python.org/packages/db/b1/9f798e745a4602ab40bf6a9174e1409dcdde6928cf800d3aab96a65b1bbf/pycodestyle-2.0.0.tar.gz"
-MD5SUM="733291d308def897c0c48c7840b7f6bc"
+DOWNLOAD="https://pypi.python.org/packages/1d/31/c63f6dbede25dc53135e54175b5cbbc4932f417e169c0a4b2339a69bffc5/pycodestyle-2.1.0.tar.gz"
+MD5SUM="1eb1f0b36abdc5e59d14d1cbbcd6a744"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""