summaryrefslogtreecommitdiffstats
path: root/python/pycryptodome
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-01-25 09:00:25 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-01-25 09:00:25 +0700
commitc0faabd379ee8266f3cde7a9ab650f3945101396 (patch)
treed30eea4479668108ee72c2a0c24cd1063b06b1a5 /python/pycryptodome
parentc205d9fa72b4821c5b34e1dd2970f81782f78843 (diff)
downloadslackbuilds-c0faabd379ee8266f3cde7a9ab650f3945101396.tar.gz
slackbuilds-c0faabd379ee8266f3cde7a9ab650f3945101396.tar.xz
python/pycryptodome: Removed (See pycryptodomex).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pycryptodome')
-rw-r--r--python/pycryptodome/README8
-rw-r--r--python/pycryptodome/pycryptodome.SlackBuild91
-rw-r--r--python/pycryptodome/pycryptodome.info10
-rw-r--r--python/pycryptodome/slack-desc19
4 files changed, 0 insertions, 128 deletions
diff --git a/python/pycryptodome/README b/python/pycryptodome/README
deleted file mode 100644
index 7b818930c5..0000000000
--- a/python/pycryptodome/README
+++ /dev/null
@@ -1,8 +0,0 @@
-PyCryptodome is a self-contained Python package of low-level cryptographic
-primitives. It supports Python 2.6 or newer, all Python 3 versions and PyPy.
-PyCryptodome is a fork of PyCrypto.
-
-PyCryptodome is not a wrapper to a separate C library like OpenSSL. To the
-largest possible extent, algorithms are implemented in pure Python. Only the
-pieces that are extremely critical to performance (e.g. block ciphers) are
-implemented as C extensions.
diff --git a/python/pycryptodome/pycryptodome.SlackBuild b/python/pycryptodome/pycryptodome.SlackBuild
deleted file mode 100644
index e17c555504..0000000000
--- a/python/pycryptodome/pycryptodome.SlackBuild
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pycryptodome
-
-# Copyright 2018 Markus Rinne Finland
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pycryptodome
-VERSION=${VERSION:-3.9.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-${VERSION}x
-tar xvf $CWD/$PRGNAM-${VERSION}x.tar.gz
-cd $PRGNAM-${VERSION}x
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS.rst Changelog.rst FuturePlans.rst INSTALL.rst LICENSE.rst README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pycryptodome/pycryptodome.info b/python/pycryptodome/pycryptodome.info
deleted file mode 100644
index db5e734031..0000000000
--- a/python/pycryptodome/pycryptodome.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pycryptodome"
-VERSION="3.9.4"
-HOMEPAGE="https://github.com/Legrandin/pycryptodome"
-DOWNLOAD="https://github.com/Legrandin/pycryptodome/archive/v3.9.4x/pycryptodome-3.9.4x.tar.gz"
-MD5SUM="f2a3057cf8c1e91ef5b9fa0889d63860"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Markus Rinne"
-EMAIL="markus.ka.rinne@gmail.com"
diff --git a/python/pycryptodome/slack-desc b/python/pycryptodome/slack-desc
deleted file mode 100644
index 987d2c3dfe..0000000000
--- a/python/pycryptodome/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pycryptodome: pycryptodome (Python Cryptography Toolkit)
-pycryptodome:
-pycryptodome: PyCryptodome is a self-contained Python package of low-level
-pycryptodome: cryptographic primitives. It supports Python 2.6 or newer, all
-pycryptodome: Python 3 versions and PyPy. PyCryptodome is a fork of PyCrypto.
-pycryptodome:
-pycryptodome: PyCryptodome is not a wrapper to a separate C library like OpenSSL.
-pycryptodome: To the largest possible extent, algorithms are implemented in pure
-pycryptodome: Python. Only the pieces that are extremely critical to performance
-pycryptodome: (e.g. block ciphers) are implemented as C extensions.
-pycryptodome: