summaryrefslogtreecommitdiffstats
path: root/python/pygame
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/pygame
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
slackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.xz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/pygame')
-rw-r--r--python/pygame/README5
-rw-r--r--python/pygame/pygame.SlackBuild53
-rw-r--r--python/pygame/pygame.info10
-rw-r--r--python/pygame/slack-desc19
4 files changed, 87 insertions, 0 deletions
diff --git a/python/pygame/README b/python/pygame/README
new file mode 100644
index 0000000000..8e7cbc387a
--- /dev/null
+++ b/python/pygame/README
@@ -0,0 +1,5 @@
+Pygame is a set of Python modules designed for writing games.
+
+It is written on top of the excellent SDL library. This allows you to create
+fully featured games and multimedia programs in the python language. Pygame
+is highly portable and runs on nearly every platform and operating system.
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
new file mode 100644
index 0000000000..e0242ddbe6
--- /dev/null
+++ b/python/pygame/pygame.SlackBuild
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+## Written by hollywoodb (hollywoodb@fastmail.fm)
+# Modified by the SlackBuilds.org project
+
+NAME=pygame
+VERSION=1.7.1
+BUILD=${BUILD:-3}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$NAME
+OUTPUT=${OUTPUT:-/tmp}
+
+SRCVERSION=${VERSION}release
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $NAME-$SRCVERSION
+tar xvf $CWD/$NAME-$SRCVERSION.tar.?z* || exit 1
+cd $NAME-$SRCVERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Python programs use the CFLAGS specified used by python itself
+python -u config.py || exit 1
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$NAME-$VERSION
+cp -a PKG-INFO WHATSNEW install.html readme.txt docs/* examples \
+ $PKG/usr/doc/$NAME-$VERSION
+cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n -p $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pygame/pygame.info b/python/pygame/pygame.info
new file mode 100644
index 0000000000..9568a4b20b
--- /dev/null
+++ b/python/pygame/pygame.info
@@ -0,0 +1,10 @@
+PRGNAM="pygame"
+VERSION="1.7.1"
+HOMEPAGE="http://www.pygame.org/"
+DOWNLOAD="http://www.pygame.org/ftp/pygame-1.7.1release.tar.gz"
+MD5SUM="05d86d1af446f79411359400951053b7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="hollywoodb"
+EMAIL="hollywoodb@fastmail.fm"
+APPROVED="rworkman"
diff --git a/python/pygame/slack-desc b/python/pygame/slack-desc
new file mode 100644
index 0000000000..17d175b84a
--- /dev/null
+++ b/python/pygame/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-------------------------------------------------------|
+pygame: pygame (a set of Python modules designed for writing games)
+pygame:
+pygame: pygame is written on top of the excellent SDL library. This allows you
+pygame: to create fully featured games and multimedia programs in the python
+pygame: language. Pygame is highly portable and runs on nearly every platform
+pygame: and operating system.
+pygame:
+pygame: Pygame is free. Released under the LGPL licence, you can create open
+pygame: source, free, freeware, shareware, and commercial games with it.
+pygame:
+pygame: