summaryrefslogtreecommitdiffstats
path: root/python/pyinotify
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-09 10:09:41 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-09 15:45:52 +0700
commitd98589bc443c838b70f0243a4c2bf94f8d79507b (patch)
treeecc8cc063a1f2ea0b01146b7be1362fcc1506fad /python/pyinotify
parent3e9e4cdcbacc4458d005577462f3d056ed71660b (diff)
downloadslackbuilds-d98589bc443c838b70f0243a4c2bf94f8d79507b.tar.gz
slackbuilds-d98589bc443c838b70f0243a4c2bf94f8d79507b.tar.xz
python/pyinotify: Build Python3 by default.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyinotify')
-rw-r--r--python/pyinotify/README4
-rw-r--r--python/pyinotify/pyinotify.SlackBuild8
2 files changed, 1 insertions, 11 deletions
diff --git a/python/pyinotify/README b/python/pyinotify/README
index fbe74a473c..40c4baeba2 100644
--- a/python/pyinotify/README
+++ b/python/pyinotify/README
@@ -2,7 +2,3 @@ Pyinotify is a Python module for monitoring filesystems changes.
Pyinotify relies on a Linux Kernel feature (merged in kernel 2.6.13)
called inotify. inotify is an event-driven notifier, its notifications
are exported from kernel space to user space through three system calls.
-
-Note: To install python3 bindings pass the variable PYTHON3=yes to the
-slackbuild.
- # PYTHON3=yes ./pyinotify.SlackBuild
diff --git a/python/pyinotify/pyinotify.SlackBuild b/python/pyinotify/pyinotify.SlackBuild
index 5c5c293748..8aaa4145af 100644
--- a/python/pyinotify/pyinotify.SlackBuild
+++ b/python/pyinotify/pyinotify.SlackBuild
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -69,10 +66,7 @@ find -L . \
sed -i '/^compile_ext_mod/s|=.*|= True|' setup.py
python setup.py install --root=$PKG
-
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true