summaryrefslogtreecommitdiffstats
path: root/python/pyparsing
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2019-01-26 08:18:48 +0100
committer Robby Workman <rworkman@slackbuilds.org>2021-04-17 23:54:38 -0500
commit9dbe1694775a30278d5f763579f0e1df83eb1344 (patch)
treec9f77b2f7c33d4499119a463bdde6746467695ea /python/pyparsing
parent2009b01baa8a650d739e5cd6f8442d74b3b41ff4 (diff)
downloadslackbuilds-9dbe1694775a30278d5f763579f0e1df83eb1344.tar.gz
slackbuilds-9dbe1694775a30278d5f763579f0e1df83eb1344.tar.xz
python/pyparsing: Removed (Added to Slackware).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/pyparsing')
-rw-r--r--python/pyparsing/README5
-rw-r--r--python/pyparsing/pyparsing.SlackBuild87
-rw-r--r--python/pyparsing/pyparsing.info10
-rw-r--r--python/pyparsing/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/python/pyparsing/README b/python/pyparsing/README
deleted file mode 100644
index ac29972273..0000000000
--- a/python/pyparsing/README
+++ /dev/null
@@ -1,5 +0,0 @@
-The pyparsing module is an alternative approach to creating and
-executing simple grammars, vs. the traditional lex/yacc
-approach, or the use of regular expressions. The pyparsing
-module provides a library of classes that client code uses to
-construct the grammar directly in Python code.
diff --git a/python/pyparsing/pyparsing.SlackBuild b/python/pyparsing/pyparsing.SlackBuild
deleted file mode 100644
index 170f8e23b7..0000000000
--- a/python/pyparsing/pyparsing.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyparsing
-
-# Copyright 2008-2012 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Updated for v2.3.1 Jan 2019
-
-PRGNAM=pyparsing
-VERSION=${VERSION:-2.3.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE PKG-INFO README.rst docs/ $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyparsing/pyparsing.info b/python/pyparsing/pyparsing.info
deleted file mode 100644
index c649ee71a9..0000000000
--- a/python/pyparsing/pyparsing.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyparsing"
-VERSION="2.3.1"
-HOMEPAGE="https://github.com/pyparsing/pyparsing"
-DOWNLOAD="https://github.com/pyparsing/pyparsing/releases/download/pyparsing_2.3.1/pyparsing-2.3.1.tar.gz"
-MD5SUM="630e86b719619a251de0ba4a97239cec"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Barry J. Grundy"
-EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/pyparsing/slack-desc b/python/pyparsing/slack-desc
deleted file mode 100644
index 2d09abba87..0000000000
--- a/python/pyparsing/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyparsing: pyparsing (parsing module for python)
-pyparsing:
-pyparsing: The pyparsing module is an alternative approach to creating and
-pyparsing: executing simple grammars, vs. the traditional lex/yacc
-pyparsing: approach, or the use of regular expressions. The pyparsing
-pyparsing: module provides a library of classes that client code uses to
-pyparsing: construct the grammar directly in Python code.
-pyparsing:
-pyparsing: Homepage: http://pyparsing.wikispaces.com/
-pyparsing:
-pyparsing: