summaryrefslogtreecommitdiffstats
path: root/python/pysetuptools
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/pysetuptools
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
slackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.xz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/pysetuptools')
-rw-r--r--python/pysetuptools/README18
-rw-r--r--python/pysetuptools/pysetuptools.SlackBuild59
-rw-r--r--python/pysetuptools/pysetuptools.info10
-rw-r--r--python/pysetuptools/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/python/pysetuptools/README b/python/pysetuptools/README
new file mode 100644
index 0000000000..851e044f23
--- /dev/null
+++ b/python/pysetuptools/README
@@ -0,0 +1,18 @@
+pysetuptools (a collection of enhancements to Python distutils)
+Note: the name of the source package is 'setuptools'. Since 'setuptools'
+is such a generic name, this package uses the name 'pysetuptools' to avoid
+any potential future conflicts. The actual installation paths and file
+names are not modified in any way.
+
+setuptools allow you to more easily build and distribute Python packages,
+especially ones that have dependencies on other packages.
+
+Packages built and distributed using setuptools look to the user like ordinary
+Python packages based on the distutils. Your users don't need to install or
+even know about setuptools in order to use them, and you don't have to include
+the entire setuptools package in your distributions. By including just a single
+bootstrap module (an 8K .py file), your package will automatically download and
+install setuptools if the user is building your package from source and doesn't
+have a suitable version already installed.
+
+Requires: >=python-2.3.5 on 32-bit systems >=python-2.4 on 64-bit systems
diff --git a/python/pysetuptools/pysetuptools.SlackBuild b/python/pysetuptools/pysetuptools.SlackBuild
new file mode 100644
index 0000000000..7b443ad754
--- /dev/null
+++ b/python/pysetuptools/pysetuptools.SlackBuild
@@ -0,0 +1,59 @@
+#!/bin/sh
+
+## Written by hollywoodb (hollywoodb@fastmail.fm)
+
+## Feel free to use, modify, redistribute this script.
+## If you make changes please modify the "Written by"
+## so that I don't recieve emails about a script I
+## did not write. Thanks.
+
+# Mofified by the SlackBuilds.org project
+
+# Maintained by Audrius Kažukauskas <audrius@neutrino.lt>
+
+PRGNAM=pysetuptools
+SRC_NAME=setuptools
+VERSION=0.6c11
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$SRC_NAME}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRC_NAME-$VERSION
+tar xvf $CWD/$SRC_NAME-$VERSION.tar.gz
+cd $SRC_NAME-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Don't need this.
+rm -f setuptools/*.exe
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m 0644 *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pysetuptools/pysetuptools.info b/python/pysetuptools/pysetuptools.info
new file mode 100644
index 0000000000..c2fad893e2
--- /dev/null
+++ b/python/pysetuptools/pysetuptools.info
@@ -0,0 +1,10 @@
+PRGNAM="pysetuptools"
+VERSION="0.6c11"
+HOMEPAGE="http://peak.telecommunity.com/DevCenter/setuptools"
+DOWNLOAD="http://pypi.python.org/packages/source/s/setuptools/setuptools-0.6c11.tar.gz"
+MD5SUM="7df2a529a074f613b509fb44feefe74e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Audrius Kazukauskas"
+EMAIL="audrius@neutrino.lt"
+APPROVED="Erik Hanson"
diff --git a/python/pysetuptools/slack-desc b/python/pysetuptools/slack-desc
new file mode 100644
index 0000000000..816e24c7c4
--- /dev/null
+++ b/python/pysetuptools/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pysetuptools: pysetuptools (a collection of enhancements to Python distutils)
+pysetuptools:
+pysetuptools: setuptools allow you to more easily build and distribute
+pysetuptools: Python packages, especially ones that have dependencies on
+pysetuptools: other packages
+pysetuptools:
+pysetuptools:
+pysetuptools:
+pysetuptools:
+pysetuptools:
+pysetuptools: