summaryrefslogtreecommitdiffstats
path: root/python/pysetuptools
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2013-07-08 14:13:39 -0500
committer Erik Hanson <erik@slackbuilds.org>2013-07-08 14:13:39 -0500
commit019a861dd9866c831b3fa0e1b0825c52a67f09d8 (patch)
tree4be72ff63490bf656305376f888853bd9c17aeb0 /python/pysetuptools
parente2715ea258645e2cf19ee6805adaf79c300b68d2 (diff)
downloadslackbuilds-019a861dd9866c831b3fa0e1b0825c52a67f09d8.tar.gz
slackbuilds-019a861dd9866c831b3fa0e1b0825c52a67f09d8.tar.xz
python/pysetuptools: Updated for version 0.8.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'python/pysetuptools')
-rw-r--r--python/pysetuptools/README8
-rw-r--r--python/pysetuptools/pysetuptools.SlackBuild59
-rw-r--r--python/pysetuptools/pysetuptools.info10
-rw-r--r--python/pysetuptools/slack-desc22
4 files changed, 51 insertions, 48 deletions
diff --git a/python/pysetuptools/README b/python/pysetuptools/README
index e22d94d54c..a828429a2a 100644
--- a/python/pysetuptools/README
+++ b/python/pysetuptools/README
@@ -6,11 +6,3 @@ names are not modified in any way.
setuptools allow you to more easily build and distribute Python packages,
especially ones that have dependencies on other packages.
-
-Packages built and distributed using setuptools look to the user like ordinary
-Python packages based on the distutils. Your users don't need to install or
-even know about setuptools in order to use them, and you don't have to include
-the entire setuptools package in your distributions. By including just a single
-bootstrap module (an 8K .py file), your package will automatically download and
-install setuptools if the user is building your package from source and doesn't
-have a suitable version already installed.
diff --git a/python/pysetuptools/pysetuptools.SlackBuild b/python/pysetuptools/pysetuptools.SlackBuild
index 7b443ad754..f3a3f266ae 100644
--- a/python/pysetuptools/pysetuptools.SlackBuild
+++ b/python/pysetuptools/pysetuptools.SlackBuild
@@ -1,59 +1,70 @@
#!/bin/sh
-## Written by hollywoodb (hollywoodb@fastmail.fm)
-
-## Feel free to use, modify, redistribute this script.
-## If you make changes please modify the "Written by"
-## so that I don't recieve emails about a script I
-## did not write. Thanks.
-
-# Mofified by the SlackBuilds.org project
-
-# Maintained by Audrius Kažukauskas <audrius@neutrino.lt>
+# Copyright 2013 Audrius Kažukauskas <audrius@neutrino.lt>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pysetuptools
-SRC_NAME=setuptools
-VERSION=0.6c11
+VERSION=${VERSION:-0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
+SRCNAM=setuptools
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$SRC_NAME}
+PKG=${PKG:-$TMP/package-$SRCNAM}
OUTPUT=${OUTPUT:-/tmp}
-set -e
+set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRC_NAME-$VERSION
-tar xvf $CWD/$SRC_NAME-$VERSION.tar.gz
-cd $SRC_NAME-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-# Don't need this.
rm -f setuptools/*.exe
-
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \;
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pysetuptools/pysetuptools.info b/python/pysetuptools/pysetuptools.info
index 2052300e0b..e04ed56992 100644
--- a/python/pysetuptools/pysetuptools.info
+++ b/python/pysetuptools/pysetuptools.info
@@ -1,10 +1,10 @@
PRGNAM="pysetuptools"
-VERSION="0.6c11"
-HOMEPAGE="http://peak.telecommunity.com/DevCenter/setuptools"
-DOWNLOAD="http://pypi.python.org/packages/source/s/setuptools/setuptools-0.6c11.tar.gz"
-MD5SUM="7df2a529a074f613b509fb44feefe74e"
+VERSION="0.8"
+HOMEPAGE="https://pypi.python.org/pypi/setuptools"
+DOWNLOAD="https://pypi.python.org/packages/source/s/setuptools/setuptools-0.8.tar.gz"
+MD5SUM="ab5f2bbc67f0dbdfeb3075f14d0b029c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Audrius Kazukauskas"
+MAINTAINER="Audrius Kažukauskas"
EMAIL="audrius@neutrino.lt"
diff --git a/python/pysetuptools/slack-desc b/python/pysetuptools/slack-desc
index 816e24c7c4..f17cc0b281 100644
--- a/python/pysetuptools/slack-desc
+++ b/python/pysetuptools/slack-desc
@@ -1,19 +1,19 @@
# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
pysetuptools: pysetuptools (a collection of enhancements to Python distutils)
pysetuptools:
-pysetuptools: setuptools allow you to more easily build and distribute
-pysetuptools: Python packages, especially ones that have dependencies on
-pysetuptools: other packages
-pysetuptools:
-pysetuptools:
-pysetuptools:
+pysetuptools: Easily build, install, upgrade, and uninstall Python packages!
pysetuptools:
+pysetuptools: Setuptools is a fully-featured, actively-maintained, and stable
+pysetuptools: library designed to facilitate packaging Python projects, where
+pysetuptools: packaging includes Python package and module definitions,
+pysetuptools: distribution package metadata, test hooks, project installation,
+pysetuptools: platform-specific details, and Python 3 support.
pysetuptools:
pysetuptools: