summaryrefslogtreecommitdiffstats
path: root/python/python-authres
diff options
context:
space:
mode:
author Christopher Walker <kris240376@gmail.com>2013-05-11 23:58:19 -0500
committer Niels Horn <niels.horn@slackbuilds.org>2013-05-12 22:21:00 -0300
commit9e8c3bff81222929c8519bce6358799f91bc2842 (patch)
treecaf63fdd36edf3ff275b157ca17f7e45ac89fcff /python/python-authres
parent64117deeb91046e006d9340f5fe3c06484512748 (diff)
downloadslackbuilds-9e8c3bff81222929c8519bce6358799f91bc2842.tar.gz
slackbuilds-9e8c3bff81222929c8519bce6358799f91bc2842.tar.xz
python/python-authres: Added (RFC 5451 Auth Results Headers generation and parsing)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python-authres')
-rw-r--r--python/python-authres/README7
-rw-r--r--python/python-authres/python-authres.SlackBuild72
-rw-r--r--python/python-authres/python-authres.info10
-rw-r--r--python/python-authres/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/python/python-authres/README b/python/python-authres/README
new file mode 100644
index 0000000000..de1c8ff506
--- /dev/null
+++ b/python/python-authres/README
@@ -0,0 +1,7 @@
+RFC 5451 Authentication-Results Headers generation and parsing for
+Python/Python3.
+
+It also supports Authentication Results extensions:
+ * RFC 5617 DKIM/ADSP
+ * RFC 6008 DKIM signature identification (header.b)
+ * RFC 6212 Vouch By Reference (VBR)
diff --git a/python/python-authres/python-authres.SlackBuild b/python/python-authres/python-authres.SlackBuild
new file mode 100644
index 0000000000..b2cbfe8be7
--- /dev/null
+++ b/python/python-authres/python-authres.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for python-authres
+
+# Copyright 2013 Chris Walker Copperas Cove, TX
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-authres
+VERSION=${VERSION:-0.501}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=authres
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+/usr/bin/python setup.py install --root $PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-authres/python-authres.info b/python/python-authres/python-authres.info
new file mode 100644
index 0000000000..10a7fb9e08
--- /dev/null
+++ b/python/python-authres/python-authres.info
@@ -0,0 +1,10 @@
+PRGNAM="python-authres"
+VERSION="0.501"
+HOMEPAGE="https://launchpad.net/authentication-results-python"
+DOWNLOAD="https://launchpad.net/authentication-results-python/0.5/0.501/+download/authres-0.501.tar.gz"
+MD5SUM="b3f51965d5b1326f7268515457ef4023"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Christopher Walker"
+EMAIL="kris240376@gmail.com"
diff --git a/python/python-authres/slack-desc b/python/python-authres/slack-desc
new file mode 100644
index 0000000000..bd4698c873
--- /dev/null
+++ b/python/python-authres/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-authres: python-authres (RFC 5451 Auth Results Headers generation and parsing)
+python-authres:
+python-authres: RFC 5451 Authentication-Results Headers generation and parsing for
+python-authres: Python/Python3.
+python-authres:
+python-authres: It also supports Authentication Results extensions:
+python-authres: * RFC 5617 DKIM/ADSP
+python-authres: * RFC 6008 DKIM signature identification (header.b)
+python-authres: * RFC 6212 Vouch By Reference (VBR)
+python-authres:
+python-authres: Homepage: https://launchpad.net/authentication-results-python