summaryrefslogtreecommitdiffstats
path: root/python/python-debian
diff options
context:
space:
mode:
author Vijay Marcel <vijaymarcel@outlook.com>2023-05-18 23:32:55 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:11 +0700
commit13edb23e68d25849ed673e95f31c53f747be9d89 (patch)
tree995c1374e7d00ba2a8199daa58066a8f2cd53c3e /python/python-debian
parent985fe1a2aad4c19904e2e81bd668872bc6567db4 (diff)
downloadslackbuilds-13edb23e68d25849ed673e95f31c53f747be9d89.tar.gz
slackbuilds-13edb23e68d25849ed673e95f31c53f747be9d89.tar.xz
python/python-debian: Updated for version 0.1.49.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-debian')
-rw-r--r--python/python-debian/changelog14
-rw-r--r--python/python-debian/python-debian.SlackBuild21
-rw-r--r--python/python-debian/python-debian.info6
3 files changed, 27 insertions, 14 deletions
diff --git a/python/python-debian/changelog b/python/python-debian/changelog
new file mode 100644
index 0000000000..5119bc4648
--- /dev/null
+++ b/python/python-debian/changelog
@@ -0,0 +1,14 @@
+Changelog for python-debian SlackBuild Script
+--------------------------------------------------------------------
+
+05/11/2022:
+
+Added to slackbuilds.org
+
+26/11/2022:
+
+gitlab tarball handling fixed by Andrew Clemons
+
+17/05/2023:
+
+Updated to version 0.1.49
diff --git a/python/python-debian/python-debian.SlackBuild b/python/python-debian/python-debian.SlackBuild
index b784bf36b2..fc4840e1ed 100644
--- a/python/python-debian/python-debian.SlackBuild
+++ b/python/python-debian/python-debian.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-debian
-# Copyright 2022 Vijay Marcel
+# Copyright 2022-2023 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-debian
-SRCNAM=python-debian-debian
-VERSION=${VERSION:-0.1.47}
+VERSION=${VERSION:-0.1.49}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -52,13 +51,13 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
+ SLKCFLAGS="-march=i586 -mtune=i686 -pipe -O2 -fPIC"
+ LIBDIRSUFFIX=""0
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2 -fPIC"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
+ SLKCFLAGS="-march=x86-64 -mtune=native -pipe -O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
@@ -72,9 +71,9 @@ trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ER
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -88,7 +87,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs examples debian README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python-debian/python-debian.info b/python/python-debian/python-debian.info
index 289b945504..9608b82c0b 100644
--- a/python/python-debian/python-debian.info
+++ b/python/python-debian/python-debian.info
@@ -1,8 +1,8 @@
PRGNAM="python-debian"
-VERSION="0.1.47"
+VERSION="0.1.49"
HOMEPAGE="https://salsa.debian.org/python-debian-team/python-debian"
-DOWNLOAD="https://salsa.debian.org/python-debian-team/python-debian/-/archive/debian/0.1.47/python-debian-debian-0.1.47.tar.gz"
-MD5SUM="74ada790bcec52b33c219a4eba061053"
+DOWNLOAD="https://salsa.debian.org/python-debian-team/python-debian/-/archive/0.1.49/python-debian-0.1.49.tar.gz"
+MD5SUM="761b78b8766de552f9d3f68c88f1599d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""