summaryrefslogtreecommitdiffstats
path: root/python/python-klein
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2017-01-30 07:34:02 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-03 04:33:08 +0700
commite1a1a7331dbd0dc6e96984befad2c7fce04c3530 (patch)
treebb7ceae868b3a6800d73a65e3fe13f03acf2d787 /python/python-klein
parentf9bbfb1262ad68fc0f266725c400122e6f1ef377 (diff)
downloadslackbuilds-e1a1a7331dbd0dc6e96984befad2c7fce04c3530.tar.gz
slackbuilds-e1a1a7331dbd0dc6e96984befad2c7fce04c3530.tar.xz
python/python-klein: Added (micro-framework for web services).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-klein')
-rw-r--r--python/python-klein/README2
-rw-r--r--python/python-klein/python-klein.SlackBuild87
-rw-r--r--python/python-klein/python-klein.info10
-rw-r--r--python/python-klein/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/python-klein/README b/python/python-klein/README
new file mode 100644
index 0000000000..e7bb343918
--- /dev/null
+++ b/python/python-klein/README
@@ -0,0 +1,2 @@
+Klein is a micro-framework for developing production-ready web services
+with Python. It has a small API similar to Bottle and Flask.
diff --git a/python/python-klein/python-klein.SlackBuild b/python/python-klein/python-klein.SlackBuild
new file mode 100644
index 0000000000..259243671f
--- /dev/null
+++ b/python/python-klein/python-klein.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for klein
+
+# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-klein
+VERSION=${VERSION:-16.12.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE NEWS.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-klein/python-klein.info b/python/python-klein/python-klein.info
new file mode 100644
index 0000000000..d50dab838b
--- /dev/null
+++ b/python/python-klein/python-klein.info
@@ -0,0 +1,10 @@
+PRGNAM="python-klein"
+VERSION="16.12.0"
+HOMEPAGE="https://klein.readthedocs.io/"
+DOWNLOAD="https://pypi.python.org/packages/01/68/f60067cfec1a43fcfa22609d91c6028c2c01c42c36a702a2a35d1dc469cb/klein-16.12.0.tar.gz"
+MD5SUM="3f692c69a1c88935682239fdf8df10a7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-twisted werkzeug"
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/python/python-klein/slack-desc b/python/python-klein/slack-desc
new file mode 100644
index 0000000000..eba10bfaf8
--- /dev/null
+++ b/python/python-klein/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-klein: python-klein (micro-framework for web services)
+python-klein:
+python-klein: Klein is a micro-framework for developing production-ready web
+python-klein: services with Python. It has a small API similar to Bottle and Flask.
+python-klein:
+python-klein: https://klein.readthedocs.io/
+python-klein:
+python-klein:
+python-klein:
+python-klein:
+python-klein: