summaryrefslogtreecommitdiffstats
path: root/python/python-x11_hash
diff options
context:
space:
mode:
author Reedych <reedych@reedych.pw>2016-11-02 20:45:09 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-11-02 22:38:02 +0700
commit8fb74869dccbfe9d88fd7e0f552ca1ed52c40a55 (patch)
tree3be0125456f9427759fc2e1932d2cde5446a0442 /python/python-x11_hash
parent46b6d3641fcde3311c94fd071cbe383692eadc0e (diff)
downloadslackbuilds-8fb74869dccbfe9d88fd7e0f552ca1ed52c40a55.tar.gz
slackbuilds-8fb74869dccbfe9d88fd7e0f552ca1ed52c40a55.tar.xz
python/python-x11_hash: Added (Python Module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-x11_hash')
-rw-r--r--python/python-x11_hash/README1
-rw-r--r--python/python-x11_hash/python-x11_hash.SlackBuild86
-rw-r--r--python/python-x11_hash/python-x11_hash.info10
-rw-r--r--python/python-x11_hash/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python-x11_hash/README b/python/python-x11_hash/README
new file mode 100644
index 0000000000..985520cd18
--- /dev/null
+++ b/python/python-x11_hash/README
@@ -0,0 +1 @@
+python-x11_hash - python module for Dash's X11 hashing.
diff --git a/python/python-x11_hash/python-x11_hash.SlackBuild b/python/python-x11_hash/python-x11_hash.SlackBuild
new file mode 100644
index 0000000000..9c8db2017f
--- /dev/null
+++ b/python/python-x11_hash/python-x11_hash.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for python-x11_hash
+
+# Copyright 2016 Reedych <reedych@reedych.pw>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-x11_hash
+SRCNAM=x11_hash
+VERSION=${VERSION:-1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-x11_hash/python-x11_hash.info b/python/python-x11_hash/python-x11_hash.info
new file mode 100644
index 0000000000..59180f92af
--- /dev/null
+++ b/python/python-x11_hash/python-x11_hash.info
@@ -0,0 +1,10 @@
+PRGNAM="python-x11_hash"
+VERSION="1.4"
+HOMEPAGE="https://github.com/mazaclub/x11_hash"
+DOWNLOAD="https://github.com/mazaclub/x11_hash/archive/x11_hash-1.4/1.4.tar.gz"
+MD5SUM="aeb83b7e868f504890a6a8d12c9ef2a0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Reedych"
+EMAIL="reedych@reedych.pw"
diff --git a/python/python-x11_hash/slack-desc b/python/python-x11_hash/slack-desc
new file mode 100644
index 0000000000..0d8fe304d0
--- /dev/null
+++ b/python/python-x11_hash/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-x11_hash: python-x11_hash (python module for Dash's X11 hashing)
+python-x11_hash:
+python-x11_hash: Python module for Dash's X11 hashing.
+python-x11_hash:
+python-x11_hash:
+python-x11_hash:
+python-x11_hash:
+python-x11_hash:
+python-x11_hash:
+python-x11_hash:
+python-x11_hash: