summaryrefslogtreecommitdiffstats
path: root/python/python-xlib
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/python-xlib
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
slackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.xz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python-xlib')
-rw-r--r--python/python-xlib/README6
-rw-r--r--python/python-xlib/python-xlib.SlackBuild49
-rw-r--r--python/python-xlib/python-xlib.info10
-rw-r--r--python/python-xlib/slack-desc19
4 files changed, 84 insertions, 0 deletions
diff --git a/python/python-xlib/README b/python/python-xlib/README
new file mode 100644
index 0000000000..49962b13a9
--- /dev/null
+++ b/python/python-xlib/README
@@ -0,0 +1,6 @@
+The Python X library is intended to be a fully functional X client for Python
+programs. It is written entirely in Python, in ontrast to earlier X libraries
+for Python. This is possible to do since X client programs communicate with
+the X server via the X protocol. The communication takes over TCP/IP, Unix
+sockets, or any other streaming network protocol.
+
diff --git a/python/python-xlib/python-xlib.SlackBuild b/python/python-xlib/python-xlib.SlackBuild
new file mode 100644
index 0000000000..866f54be3e
--- /dev/null
+++ b/python/python-xlib/python-xlib.SlackBuild
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# Slackware build script for python-xlib
+# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
+
+# Modified by the SlackBuilds.org project
+
+PRGNAM=python-xlib
+VERSION=0.14
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="COPYING NEWS PKG-INFO README TODO"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py install --root $PKG || exit 1
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-xlib/python-xlib.info b/python/python-xlib/python-xlib.info
new file mode 100644
index 0000000000..597f28f6bc
--- /dev/null
+++ b/python/python-xlib/python-xlib.info
@@ -0,0 +1,10 @@
+PRGNAM="python-xlib"
+VERSION="0.14"
+HOMEPAGE="http://python-xlib.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/python-xlib/python-xlib-0.14.tar.gz"
+MD5SUM="a038c2f410d8445f3fa8f6dcd45659c5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Vasilis Papavasileiou"
+EMAIL="el03020@mail.ntua.gr"
+APPROVED="rworkman"
diff --git a/python/python-xlib/slack-desc b/python/python-xlib/slack-desc
new file mode 100644
index 0000000000..8e4e0d54e4
--- /dev/null
+++ b/python/python-xlib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-xlib: python-xlib (X Library module for Python)
+python-xlib:
+python-xlib: The Python X library is intended to be a fully functional X
+python-xlib: client for Python programs. It is written entirely in Python, in
+python-xlib: contrast to earlier X libraries for Python. This is possible to
+python-xlib: do since X client programs communicate with the X server via the
+python-xlib: X protocol. The communication takes over TCP/IP, Unix sockets, or
+python-xlib: any other streaming network protocol.
+python-xlib:
+python-xlib: Homepage: http://python-xlib.sourceforge.net/
+python-xlib: