summaryrefslogtreecommitdiffstats
path: root/python/python2-docker-pycreds
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:16 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:48 +0700
commit0b20b748053c2d16ed6c47600852701190534c48 (patch)
tree43b724f947257e78cc3f59bd7be7352212db1f98 /python/python2-docker-pycreds
parent6573ca7250558a56902cddf70188f25bbcde61d7 (diff)
downloadslackbuilds-0b20b748053c2d16ed6c47600852701190534c48.tar.gz
slackbuilds-0b20b748053c2d16ed6c47600852701190534c48.tar.xz
python/python-docker-pycreds: Renamed python2-docker-pycreds.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-docker-pycreds')
-rw-r--r--python/python2-docker-pycreds/README1
-rw-r--r--python/python2-docker-pycreds/python2-docker-pycreds.SlackBuild70
-rw-r--r--python/python2-docker-pycreds/python2-docker-pycreds.info10
-rw-r--r--python/python2-docker-pycreds/slack-desc19
4 files changed, 100 insertions, 0 deletions
diff --git a/python/python2-docker-pycreds/README b/python/python2-docker-pycreds/README
new file mode 100644
index 0000000000..c3e227188f
--- /dev/null
+++ b/python/python2-docker-pycreds/README
@@ -0,0 +1 @@
+Python bindings for the docker credentials store API.
diff --git a/python/python2-docker-pycreds/python2-docker-pycreds.SlackBuild b/python/python2-docker-pycreds/python2-docker-pycreds.SlackBuild
new file mode 100644
index 0000000000..df1e356c48
--- /dev/null
+++ b/python/python2-docker-pycreds/python2-docker-pycreds.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for python-docker-pycreds
+
+# Copyright 2017-2018 Audrius Kažukauskas <audrius@neutrino.lt>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python2-docker-pycreds
+VERSION=${VERSION:-0.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-docker-pycreds/python2-docker-pycreds.info b/python/python2-docker-pycreds/python2-docker-pycreds.info
new file mode 100644
index 0000000000..d74ed50827
--- /dev/null
+++ b/python/python2-docker-pycreds/python2-docker-pycreds.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-docker-pycreds"
+VERSION="0.2.3"
+HOMEPAGE="https://github.com/shin-/dockerpy-creds"
+DOWNLOAD="https://files.pythonhosted.org/packages/fc/29/f0fe6e6a055ebfc224f952d1166aea7bccd7de38ac01842fcbffe10ec0b8/docker-pycreds-0.2.3.tar.gz"
+MD5SUM="cc70dd941160f7f7db56b9c8c8ca2d54"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Audrius Kažukauskas"
+EMAIL="audrius@neutrino.lt"
diff --git a/python/python2-docker-pycreds/slack-desc b/python/python2-docker-pycreds/slack-desc
new file mode 100644
index 0000000000..32e18995d2
--- /dev/null
+++ b/python/python2-docker-pycreds/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-docker-pycreds: python2-docker-pycreds (bindings for docker credentials store API)
+python2-docker-pycreds:
+python2-docker-pycreds: Homepage: https://github.com/shin-/dockerpy-creds
+python2-docker-pycreds:
+python2-docker-pycreds:
+python2-docker-pycreds:
+python2-docker-pycreds:
+python2-docker-pycreds:
+python2-docker-pycreds:
+python2-docker-pycreds:
+python2-docker-pycreds: