summaryrefslogtreecommitdiffstats
path: root/python/python2-netaddr
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-03 06:50:16 +0100
committer Robby Workman <rworkman@slackbuilds.org>2021-05-03 01:49:57 -0500
commit14073927a21038c28368171c102782412fc86a07 (patch)
tree2d19920d810cefade916bbe3df92a675e9ab2ba9 /python/python2-netaddr
parent3a757a750dc094f6bd49281283ed3e44f7a6b413 (diff)
downloadslackbuilds-14073927a21038c28368171c102782412fc86a07.tar.gz
slackbuilds-14073927a21038c28368171c102782412fc86a07.tar.xz
python/python-netaddr: Renamed python2-netaddr.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python2-netaddr')
-rw-r--r--python/python2-netaddr/README20
-rw-r--r--python/python2-netaddr/python2-netaddr.SlackBuild101
-rw-r--r--python/python2-netaddr/python2-netaddr.info10
-rw-r--r--python/python2-netaddr/slack-desc19
4 files changed, 150 insertions, 0 deletions
diff --git a/python/python2-netaddr/README b/python/python2-netaddr/README
new file mode 100644
index 0000000000..686ffe012c
--- /dev/null
+++ b/python/python2-netaddr/README
@@ -0,0 +1,20 @@
+A pure Python network address representation and manipulation library.
+
+netaddr provides a Pythonic way of working with :-
+- IPv4 and IPv6 addresses and subnets
+- MAC addresses, OUI and IAB identifiers, IEEE EUI-64 identifiers
+- arbitrary (non-aligned) IP address ranges and IP address sets
+- various non-CIDR IP range formats such as nmap and glob-style formats
+
+The source package includes (probably now out of date) data from:
+1. http://standards.ieee.org (public OUI and IAB registration data
+published by the IEEE)
+2. http://www.iana.org (IPv4, IPv6 and multicast address space
+allocations).
+
+To include the latest versions in the package, run the script with:
+
+# NEWDATA="yes" ./python-netaddr.SlackBuild
+
+and the latest versions will be downloaded during the build
+for inclusion in the package.
diff --git a/python/python2-netaddr/python2-netaddr.SlackBuild b/python/python2-netaddr/python2-netaddr.SlackBuild
new file mode 100644
index 0000000000..7291fc1d8e
--- /dev/null
+++ b/python/python2-netaddr/python2-netaddr.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# Slackware build script for python-netaddr
+
+# Copyright 2013-2020 Christoph Willing, Brisbane Australia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python2-netaddr
+SRC_PRGNAM=netaddr
+VERSION=${VERSION:-0.8.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -ev
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRC_PRGNAM-$VERSION
+tar xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
+cd $SRC_PRGNAM-$VERSION
+
+if [ ${NEWDATA:-no} = "yes" ]; then
+ echo 'downloading latest IEEE data'
+ (cd netaddr/eui/ && wget -N http://standards.ieee.org/regauth/oui/oui.txt)
+ (cd netaddr/eui/ && wget -N http://standards.ieee.org/regauth/oui/iab.txt)
+ echo 'rebuilding IEEE data file indices'
+ PYTHONPATH="." python netaddr/eui/ieee.py
+ echo 'downloading latest IANA data'
+ (cd netaddr/ip/ && wget -N http://www.iana.org/assignments/ipv4-address-space/ipv4-address-space.xml)
+ (cd netaddr/ip/ && wget -N http://www.iana.org/assignments/ipv6-address-space/ipv6-address-space.xml)
+ (cd netaddr/ip/ && wget -N http://www.iana.org/assignments/multicast-addresses/multicast-addresses.xml)
+fi
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/* \
+ AUTHORS CHANGELOG COPYRIGHT LICENSE README* REFERENCES \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-netaddr/python2-netaddr.info b/python/python2-netaddr/python2-netaddr.info
new file mode 100644
index 0000000000..2b03deaf76
--- /dev/null
+++ b/python/python2-netaddr/python2-netaddr.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-netaddr"
+VERSION="0.8.0"
+HOMEPAGE="https://pypi.python.org/pypi/netaddr"
+DOWNLOAD="https://files.pythonhosted.org/packages/c3/3b/fe5bda7a3e927d9008c897cf1a0858a9ba9924a6b4750ec1824c9e617587/netaddr-0.8.0.tar.gz"
+MD5SUM="34cad578473b66ad77bc3b2a7613ed4a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Christoph Willing"
+EMAIL="chris.willing@linux.com"
diff --git a/python/python2-netaddr/slack-desc b/python/python2-netaddr/slack-desc
new file mode 100644
index 0000000000..fa83a05f7f
--- /dev/null
+++ b/python/python2-netaddr/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-netaddr: python2-netaddr (Network address manipulation)
+python2-netaddr:
+python2-netaddr: netaddr provides a Pythonic way of working with:
+python2-netaddr: - IPv4 and IPv6 addresses and subnets
+python2-netaddr: - MAC addresses, OUI and IAB identifiers, IEEE EUI-64 identifiers
+python2-netaddr: - arbitrary (non-aligned) IP address ranges and IP address sets
+python2-netaddr: - some non-CIDR IP range formats such as nmap and glob-style formats
+python2-netaddr:
+python2-netaddr: nettaddr is able to manipulate IPv4, IPv6, CIDR, EUI and MAC
+python2-netaddr: network addresses.
+python2-netaddr: