summaryrefslogtreecommitdiffstats
path: root/python/python2-twitter
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:45 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:03 +0700
commit1fb3a2c91212a810ac2225cd395c08531e9e4bb1 (patch)
treea74c596eccf10ece78de8628c97179c6c5249a8a /python/python2-twitter
parenta966933011ab23f79d92db3fd99588365d5f3d77 (diff)
downloadslackbuilds-1fb3a2c91212a810ac2225cd395c08531e9e4bb1.tar.gz
slackbuilds-1fb3a2c91212a810ac2225cd395c08531e9e4bb1.tar.xz
python/python-twitter: Renamed python2-twitter.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-twitter')
-rw-r--r--python/python2-twitter/README6
-rw-r--r--python/python2-twitter/python2-twitter.SlackBuild72
-rw-r--r--python/python2-twitter/python2-twitter.info10
-rw-r--r--python/python2-twitter/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/python/python2-twitter/README b/python/python2-twitter/README
new file mode 100644
index 0000000000..547d66b606
--- /dev/null
+++ b/python/python2-twitter/README
@@ -0,0 +1,6 @@
+This library provides a pure python interface for the Twitter API.
+
+Twitter (http://twitter.com) provides a service that allows people
+to connect via the web, IM, and SMS. Twitter exposes a web services
+API (http://twitter.com/help/api) and this library is intended to
+make it even easier for python programmers to use.
diff --git a/python/python2-twitter/python2-twitter.SlackBuild b/python/python2-twitter/python2-twitter.SlackBuild
new file mode 100644
index 0000000000..ada3d2c3ac
--- /dev/null
+++ b/python/python2-twitter/python2-twitter.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for python-twitter
+# Written by Steven Pledger <piratesmack@ymail.com>
+# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python2-twitter
+SRCNAM=python-twitter
+VERSION=${VERSION:-3.4.2}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES COPYING LICENSE NOTICE PKG-INFO *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-twitter/python2-twitter.info b/python/python2-twitter/python2-twitter.info
new file mode 100644
index 0000000000..619161262d
--- /dev/null
+++ b/python/python2-twitter/python2-twitter.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-twitter"
+VERSION="3.4.2"
+HOMEPAGE="https://github.com/bear/python-twitter"
+DOWNLOAD="https://files.pythonhosted.org/packages/12/df/cf1f6f1cf736380bb6b828c44fea9660b86d7de756bb4d5c3db70b2f3f17/python-twitter-3.4.2.tar.gz"
+MD5SUM="5919b8ccac604b49c5dc9851b8686e26"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pytest-runner requests-oauthlib"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python2-twitter/slack-desc b/python/python2-twitter/slack-desc
new file mode 100644
index 0000000000..80704c15d3
--- /dev/null
+++ b/python/python2-twitter/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-twitter: python2-twitter (python wrapper around the Twitter API)
+python2-twitter:
+python2-twitter: This library provides a pure python interface for the Twitter API.
+python2-twitter:
+python2-twitter: Homepage: https://github.com/bear/python-twitter
+python2-twitter:
+python2-twitter:
+python2-twitter:
+python2-twitter:
+python2-twitter:
+python2-twitter: