summaryrefslogtreecommitdiffstats
path: root/python/python3-backlash
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-03-08 22:04:06 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 09:40:17 +0700
commit06cf37d60ef5b90995c6bd7d9166de56d3b7e073 (patch)
treee768f00d3573e07faeb9a3d673e04320b012589a /python/python3-backlash
parent9a9964d19d161cf72df17316790e821f55056884 (diff)
downloadslackbuilds-06cf37d60ef5b90995c6bd7d9166de56d3b7e073.tar.gz
slackbuilds-06cf37d60ef5b90995c6bd7d9166de56d3b7e073.tar.xz
python/python3-backlash: renamed from backlash for python3, updated for version 0.3.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-backlash')
-rw-r--r--python/python3-backlash/README13
-rw-r--r--python/python3-backlash/python3-backlash.SlackBuild77
-rw-r--r--python/python3-backlash/python3-backlash.info10
-rw-r--r--python/python3-backlash/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/python3-backlash/README b/python/python3-backlash/README
new file mode 100644
index 0000000000..8c51e16ce3
--- /dev/null
+++ b/python/python3-backlash/README
@@ -0,0 +1,13 @@
+Backlash supports both debugging applications on crash and realtime
+console, both are based on the Werkzeug Debugger and adapted to work
+with WebOb.
+
+backlash is a swiss army knife for web applications debugging, which
+provides:
+ An Interactive In Browser Debugger based on a Werkzeug Debugger fork
+ ported to WebOb
+ Crash reporting by email and on Sentry
+ Slow requests reporting by email and on Sentry.
+
+Backlash was born as a replacement for WebError in TurboGears2.3
+versions.
diff --git a/python/python3-backlash/python3-backlash.SlackBuild b/python/python3-backlash/python3-backlash.SlackBuild
new file mode 100644
index 0000000000..fec4117246
--- /dev/null
+++ b/python/python3-backlash/python3-backlash.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild script for backlash.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-backlash
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-0.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-backlash/python3-backlash.info b/python/python3-backlash/python3-backlash.info
new file mode 100644
index 0000000000..d0affbb03e
--- /dev/null
+++ b/python/python3-backlash/python3-backlash.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-backlash"
+VERSION="0.3.1"
+HOMEPAGE="https://github.com/TurboGears/backlash"
+DOWNLOAD="https://pypi.python.org/packages/source/b/backlash/backlash-0.3.1.tar.gz"
+MD5SUM="c80c065e33b6891c5e5ac70ac3a2551c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-webob"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-backlash/slack-desc b/python/python3-backlash/slack-desc
new file mode 100644
index 0000000000..bc75b7ad9c
--- /dev/null
+++ b/python/python3-backlash/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-backlash: python3-backlash (Python Module)
+python3-backlash:
+python3-backlash: Standalone WebOb port of the Werkzeug Debugger with Python3 support
+python3-backlash: born as a WebError replacement for TurboGears2.
+python3-backlash:
+python3-backlash: backlash is a swiss army knife for web applications debugging,
+python3-backlash: which provides:
+python3-backlash: * An Interactive In Browser Debugger based on a Werkzeug Debugger
+python3-backlash: fork ported to WebOb
+python3-backlash: * Crash reporting by email and on Sentry
+python3-backlash: * Slow requests reporting by email and on Sentry.