summaryrefslogtreecommitdiffstats
path: root/python/python3-bcrypt
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-03-08 22:06:21 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 09:41:09 +0700
commit5bcf2801eff053d2f38f39c0730cbcf73cae7605 (patch)
tree878077686399dc648b2c14fc28fed0acd2385535 /python/python3-bcrypt
parent06cf37d60ef5b90995c6bd7d9166de56d3b7e073 (diff)
downloadslackbuilds-5bcf2801eff053d2f38f39c0730cbcf73cae7605.tar.gz
slackbuilds-5bcf2801eff053d2f38f39c0730cbcf73cae7605.tar.xz
python/python3-bcrypt: renamed from bcrypt for python3, updated for version 3.2.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-bcrypt')
-rw-r--r--python/python3-bcrypt/README1
-rw-r--r--python/python3-bcrypt/python3-bcrypt.SlackBuild77
-rw-r--r--python/python3-bcrypt/python3-bcrypt.info10
-rw-r--r--python/python3-bcrypt/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/python/python3-bcrypt/README b/python/python3-bcrypt/README
new file mode 100644
index 0000000000..f7692c8759
--- /dev/null
+++ b/python/python3-bcrypt/README
@@ -0,0 +1 @@
+Modern(-ish) password hashing for your software and your servers
diff --git a/python/python3-bcrypt/python3-bcrypt.SlackBuild b/python/python3-bcrypt/python3-bcrypt.SlackBuild
new file mode 100644
index 0000000000..51299e3940
--- /dev/null
+++ b/python/python3-bcrypt/python3-bcrypt.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild script for bcrypt.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-bcrypt
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-3.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-bcrypt/python3-bcrypt.info b/python/python3-bcrypt/python3-bcrypt.info
new file mode 100644
index 0000000000..bb3b71f54b
--- /dev/null
+++ b/python/python3-bcrypt/python3-bcrypt.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-bcrypt"
+VERSION="3.2.0"
+HOMEPAGE="https://github.com/pyca/bcrypt/"
+DOWNLOAD="https://pypi.python.org/packages/source/b/bcrypt/bcrypt-3.2.0.tar.gz"
+MD5SUM="fe31390dab603728f756cd3d6830c80a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-bcrypt/slack-desc b/python/python3-bcrypt/slack-desc
new file mode 100644
index 0000000000..94daa45933
--- /dev/null
+++ b/python/python3-bcrypt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-bcrypt: python3-bcrypt (password hashing)
+python3-bcrypt:
+python3-bcrypt: Modern(-ish) password hashing for your software and your servers
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt:
+python3-bcrypt: