summaryrefslogtreecommitdiffstats
path: root/python/python3-formencode
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-03-08 23:44:40 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 12:34:23 +0700
commit0018c5a373468abfdf4e7774b5d0467513b75075 (patch)
treef4a6d218e96cd985165d7f0ff1e2c219c2a7848a /python/python3-formencode
parent2293b85eb1b19ab94ccb80e8ce76736d5108f737 (diff)
downloadslackbuilds-0018c5a373468abfdf4e7774b5d0467513b75075.tar.gz
slackbuilds-0018c5a373468abfdf4e7774b5d0467513b75075.tar.xz
python/python3-formencode: cloned from FormEncode for python3, updated for version 2.0.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-formencode')
-rw-r--r--python/python3-formencode/README6
-rw-r--r--python/python3-formencode/python3-formencode.SlackBuild80
-rw-r--r--python/python3-formencode/python3-formencode.info10
-rw-r--r--python/python3-formencode/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/python3-formencode/README b/python/python3-formencode/README
new file mode 100644
index 0000000000..8072779675
--- /dev/null
+++ b/python/python3-formencode/README
@@ -0,0 +1,6 @@
+FormEncode validates and converts nested structures. It allows for a
+declarative form of defining the validation, and decoupled processes
+for filling and generating forms.
+
+Optional dependencies are Sphinx, used to generate the docs, and
+nose, to run the test suite.
diff --git a/python/python3-formencode/python3-formencode.SlackBuild b/python/python3-formencode/python3-formencode.SlackBuild
new file mode 100644
index 0000000000..f902c512e9
--- /dev/null
+++ b/python/python3-formencode/python3-formencode.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/bash
+
+# Slackware build script for python3-FormEncode
+
+# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-formencode
+SRCNAM=FormEncode
+VERSION=${VERSION:-2.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+./regen-docs || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
+cp -a docs/_build/* $PKG/usr/doc/$PRGNAM-$VERSION/html || \
+ cp -a docs $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-formencode/python3-formencode.info b/python/python3-formencode/python3-formencode.info
new file mode 100644
index 0000000000..59f47704f9
--- /dev/null
+++ b/python/python3-formencode/python3-formencode.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-formencode"
+VERSION="2.0.1"
+HOMEPAGE="http://FormEncode.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/F/FormEncode/FormEncode-2.0.1.tar.gz"
+MD5SUM="65a9ba7220890c3d26904bdafe3a5a35"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-setuptools_scm_git_archive"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-formencode/slack-desc b/python/python3-formencode/slack-desc
new file mode 100644
index 0000000000..25a96673fc
--- /dev/null
+++ b/python/python3-formencode/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-formencode: python3-formencode (HTML form validation)
+python3-formencode:
+python3-formencode: FormEncode validates and converts nested structures. It allows for a
+python3-formencode: declarative form of defining the validation, and decoupled processes
+python3-formencode: for filling and generating forms.
+python3-formencode:
+python3-formencode: http://FormEncode.org/
+python3-formencode:
+python3-formencode:
+python3-formencode:
+python3-formencode: