summaryrefslogtreecommitdiffstats
path: root/python/python3-mccabe
diff options
context:
space:
mode:
author Markus Rinne <markus.ka.rinne@gmail.com>2018-08-13 00:01:18 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-08-18 08:39:47 +0700
commit92d1ce84b6bb23d20ec890afa5a48d7f9a447f9d (patch)
treed72adf7af39072693cd1aff719462993fbd44513 /python/python3-mccabe
parenta898895a64cfbe451db78c32cd320d781ca7ddc6 (diff)
downloadslackbuilds-92d1ce84b6bb23d20ec890afa5a48d7f9a447f9d.tar.gz
slackbuilds-92d1ce84b6bb23d20ec890afa5a48d7f9a447f9d.tar.xz
python/python3-mccabe: Added (Complexity checker for Python).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/python3-mccabe')
-rw-r--r--python/python3-mccabe/README5
-rw-r--r--python/python3-mccabe/python3-mccabe.SlackBuild88
-rw-r--r--python/python3-mccabe/python3-mccabe.info10
-rw-r--r--python/python3-mccabe/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/python3-mccabe/README b/python/python3-mccabe/README
new file mode 100644
index 0000000000..8294c57e46
--- /dev/null
+++ b/python/python3-mccabe/README
@@ -0,0 +1,5 @@
+McCabe checker, plugin for flake8. Ned's script to
+check McCabe complexity. This module provides a plugin
+for flake8, the Python code checker.
+
+Dependency pytest-runner must be built with Python 3 support.
diff --git a/python/python3-mccabe/python3-mccabe.SlackBuild b/python/python3-mccabe/python3-mccabe.SlackBuild
new file mode 100644
index 0000000000..fd3b130bc4
--- /dev/null
+++ b/python/python3-mccabe/python3-mccabe.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for python3-mccabe
+
+# Copyright 2018 Markus Rinne Finland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-mccabe
+SRCNAM=mccabe
+VERSION=${VERSION:-0.6.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-mccabe/python3-mccabe.info b/python/python3-mccabe/python3-mccabe.info
new file mode 100644
index 0000000000..a838929c60
--- /dev/null
+++ b/python/python3-mccabe/python3-mccabe.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-mccabe"
+VERSION="0.6.1"
+HOMEPAGE="https://github.com/flintwork/mccabe"
+DOWNLOAD="https://pypi.python.org/packages/06/18/fa675aa501e11d6d6ca0ae73a101b2f3571a565e0f7d38e062eec18a91ee/mccabe-0.6.1.tar.gz"
+MD5SUM="723df2f7b1737b8887475bac4c763e1e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 pytest-runner"
+MAINTAINER="Markus Rinne"
+EMAIL="markus.ka.rinne@gmail.com"
diff --git a/python/python3-mccabe/slack-desc b/python/python3-mccabe/slack-desc
new file mode 100644
index 0000000000..9f2f1be0fb
--- /dev/null
+++ b/python/python3-mccabe/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-mccabe: python3-mccabe (Complexity checker for Python)
+python3-mccabe:
+python3-mccabe: McCabe checker, plugin for flake8. Ned's script to check McCabe
+python3-mccabe: complexity. This module provides a plugin for flake8, the Python
+python3-mccabe: code checker.
+python3-mccabe:
+python3-mccabe: Homepage: https://github.com/flintwork/mccabe
+python3-mccabe:
+python3-mccabe:
+python3-mccabe:
+python3-mccabe: