summaryrefslogtreecommitdiffstats
path: root/python/python3-paramiko
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2022-01-23 11:06:46 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-01-25 14:44:38 +0700
commita706820fa0860bb7e46f2dc1f33d666f214d8d39 (patch)
tree2b353af35b3155853d41fc9308c96d67e8a03dc5 /python/python3-paramiko
parent442c1c3a9dec40d955525be2ff8e1535598e6e1b (diff)
downloadslackbuilds-a706820fa0860bb7e46f2dc1f33d666f214d8d39.tar.gz
slackbuilds-a706820fa0860bb7e46f2dc1f33d666f214d8d39.tar.xz
python/python3-paramiko: Added (Python3 SSH module)
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-paramiko')
-rw-r--r--python/python3-paramiko/README6
-rw-r--r--python/python3-paramiko/python3-paramiko.SlackBuild82
-rw-r--r--python/python3-paramiko/python3-paramiko.info10
-rw-r--r--python/python3-paramiko/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/python3-paramiko/README b/python/python3-paramiko/README
new file mode 100644
index 0000000000..580e46a714
--- /dev/null
+++ b/python/python3-paramiko/README
@@ -0,0 +1,6 @@
+"paramiko" is a combination of the esperanto words for "paranoid"
+and "friend". it's a module for python 2.2+ that implements the
+SSH2 protocol for secure (encrypted and authenticated) connections
+to remote machines. Unlike SSL (aka TLS), SSH2 protocol does not
+require heirarchical certificates signed by a powerful central
+authority.
diff --git a/python/python3-paramiko/python3-paramiko.SlackBuild b/python/python3-paramiko/python3-paramiko.SlackBuild
new file mode 100644
index 0000000000..b6ae936a75
--- /dev/null
+++ b/python/python3-paramiko/python3-paramiko.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Slackware build script for python3-paramiko
+
+# Copyright 2008-2022 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-paramiko
+SRCNAM=paramiko
+VERSION=${VERSION:-2.9.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst docs $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-paramiko/python3-paramiko.info b/python/python3-paramiko/python3-paramiko.info
new file mode 100644
index 0000000000..8e05a98dfb
--- /dev/null
+++ b/python/python3-paramiko/python3-paramiko.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-paramiko"
+VERSION="2.9.2"
+HOMEPAGE="http://www.paramiko.org/"
+DOWNLOAD="https://files.pythonhosted.org/packages/ea/01/f4c41238b4e4cae41502598c79a62785bdfe9fb5bb54728775805bd0b5d8/paramiko-2.9.2.tar.gz"
+MD5SUM="df65b3d7e0cfe6a4afe14b570d2ef240"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="cryptography"
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@slackbuilds.org"
diff --git a/python/python3-paramiko/slack-desc b/python/python3-paramiko/slack-desc
new file mode 100644
index 0000000000..b0c2f98cdc
--- /dev/null
+++ b/python/python3-paramiko/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-paramiko: python3-paramiko (Python3 SSH module)
+python3-paramiko:
+python3-paramiko: "paramiko" is a combination of the esperanto words for "paranoid"
+python3-paramiko: and "friend". it's a module for python 2.2+ that implements the
+python3-paramiko: SSH2 protocol for secure (encrypted and authenticated) connections
+python3-paramiko: to remote machines. Unlike SSL (aka TLS), SSH2 protocol does not
+python3-paramiko: require heirarchical certificates signed by a powerful central
+python3-paramiko: authority.
+python3-paramiko:
+python3-paramiko: Homepage: http://www.lag.net/paramiko/
+python3-paramiko: