summaryrefslogtreecommitdiffstats
path: root/python/python3-pastedeploy
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-03-08 23:27:48 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 09:51:46 +0700
commitd888ea45122a41b04a96c6da904ca592f694665c (patch)
tree5db6959173a447247e3bb34fc952cff73f69501f /python/python3-pastedeploy
parent671796db20e4eba791c537abce15033b90db2848 (diff)
downloadslackbuilds-d888ea45122a41b04a96c6da904ca592f694665c.tar.gz
slackbuilds-d888ea45122a41b04a96c6da904ca592f694665c.tar.xz
python/python3-pastedeploy: renamed from PasteDeploy for python3, updated for version 2.1.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-pastedeploy')
-rw-r--r--python/python3-pastedeploy/README15
-rw-r--r--python/python3-pastedeploy/python3-pastedeploy.SlackBuild77
-rw-r--r--python/python3-pastedeploy/python3-pastedeploy.info10
-rw-r--r--python/python3-pastedeploy/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/python3-pastedeploy/README b/python/python3-pastedeploy/README
new file mode 100644
index 0000000000..c77a6ee274
--- /dev/null
+++ b/python/python3-pastedeploy/README
@@ -0,0 +1,15 @@
+Paste Deployment is a system for finding and configuring WSGI
+applications and servers. For WSGI application consumers it provides a
+single, simple function (loadapp) for loading a WSGI application from a
+configuration file or a Python Egg.
+
+For WSGI application providers it only asks for a single, simple entry
+point to your application, so that application users don't need to be
+exposed to the implementation details of your application.
+
+The result is something a system administrator can install and manage
+without knowing any Python, or the details of the WSGI application or
+its container.
+
+Paste Deployment currently does not require other parts of Paste, and is
+distributed as a separate package.
diff --git a/python/python3-pastedeploy/python3-pastedeploy.SlackBuild b/python/python3-pastedeploy/python3-pastedeploy.SlackBuild
new file mode 100644
index 0000000000..eaa751b29d
--- /dev/null
+++ b/python/python3-pastedeploy/python3-pastedeploy.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild script for PasteDeploy.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pastedeploy
+SRCNAM=PasteDeploy
+VERSION=${VERSION:-2.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pastedeploy/python3-pastedeploy.info b/python/python3-pastedeploy/python3-pastedeploy.info
new file mode 100644
index 0000000000..748f64ef26
--- /dev/null
+++ b/python/python3-pastedeploy/python3-pastedeploy.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pastedeploy"
+VERSION="2.1.1"
+HOMEPAGE="https://pylonsproject.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/P/PasteDeploy/PasteDeploy-2.1.1.tar.gz"
+MD5SUM="bc13219866a524626aee97127afa0348"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-pastedeploy/slack-desc b/python/python3-pastedeploy/slack-desc
new file mode 100644
index 0000000000..ff0a629cab
--- /dev/null
+++ b/python/python3-pastedeploy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pastedeploy: python3-pastedeploy (Python tool)
+python3-pastedeploy:
+python3-pastedeploy: This tool provides code to load WSGI applications and servers from
+python3-pastedeploy: URIs.
+python3-pastedeploy:
+python3-pastedeploy: These URIs can refer to Python eggs for INI-style configuration files
+python3-pastedeploy:
+python3-pastedeploy: Paste Script provides commands to serve applications based on this
+python3-pastedeploy: configuration file.
+python3-pastedeploy:
+python3-pastedeploy: