summaryrefslogtreecommitdiffstats
path: root/python/python3-soupsieve
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-15 13:55:26 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-16 12:11:30 +0700
commitcedb79443dc84e4700bd972b4ef0934bed96c219 (patch)
tree4d18ad15db1f83df910f7760abe1f40c8d8eb507 /python/python3-soupsieve
parentc6d0e105e462a0b99029d27b2dcc7ddd5e250661 (diff)
downloadslackbuilds-cedb79443dc84e4700bd972b4ef0934bed96c219.tar.gz
slackbuilds-cedb79443dc84e4700bd972b4ef0934bed96c219.tar.xz
python/python3-soupsieve: Fix docs.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-soupsieve')
-rw-r--r--python/python3-soupsieve/python3-soupsieve.SlackBuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/python/python3-soupsieve/python3-soupsieve.SlackBuild b/python/python3-soupsieve/python3-soupsieve.SlackBuild
index 4eb1b0ae1d..2fa1570943 100644
--- a/python/python3-soupsieve/python3-soupsieve.SlackBuild
+++ b/python/python3-soupsieve/python3-soupsieve.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220415 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - clean up the doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-soupsieve
VERSION=${VERSION:-2.3.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -77,17 +77,20 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220415 bkw: since we can't build the HTML docs from the markdown
+# source (we lack the tools), just put the markdown files in the doc dir.
+# they're pretty readable as-is.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md docs/ requirements/ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md docs/src/markdown/{*.md,selectors,about} $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install