summaryrefslogtreecommitdiffstats
path: root/python/python3-tgext.routes
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-03-08 23:19:36 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 09:46:34 +0700
commita2dc8be5ecbfa5187f039731a22c907d96e30efd (patch)
tree2a687b6d8a4eb033726e5c700ea282e84b539e52 /python/python3-tgext.routes
parent7151462c1387251203df19f7401a51e5d429bcb5 (diff)
downloadslackbuilds-a2dc8be5ecbfa5187f039731a22c907d96e30efd.tar.gz
slackbuilds-a2dc8be5ecbfa5187f039731a22c907d96e30efd.tar.xz
python/python3-tgext.routes: renamed from tgext.routes for python3, updated for version 0.2.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-tgext.routes')
-rw-r--r--python/python3-tgext.routes/README2
-rw-r--r--python/python3-tgext.routes/python3-tgext.routes.SlackBuild77
-rw-r--r--python/python3-tgext.routes/python3-tgext.routes.info10
-rw-r--r--python/python3-tgext.routes/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/python/python3-tgext.routes/README b/python/python3-tgext.routes/README
new file mode 100644
index 0000000000..e67a13791e
--- /dev/null
+++ b/python/python3-tgext.routes/README
@@ -0,0 +1,2 @@
+tgext.routes provides a simple way to integrate routes based dispatch
+into TurboGears2 applications.
diff --git a/python/python3-tgext.routes/python3-tgext.routes.SlackBuild b/python/python3-tgext.routes/python3-tgext.routes.SlackBuild
new file mode 100644
index 0000000000..ca30a5e639
--- /dev/null
+++ b/python/python3-tgext.routes/python3-tgext.routes.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild script for tgext.routes.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-tgext.routes
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-0.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-tgext.routes/python3-tgext.routes.info b/python/python3-tgext.routes/python3-tgext.routes.info
new file mode 100644
index 0000000000..23988c2770
--- /dev/null
+++ b/python/python3-tgext.routes/python3-tgext.routes.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-tgext.routes"
+VERSION="0.2.1"
+HOMEPAGE="https://github.com/TurboGears/tgext.routes"
+DOWNLOAD="https://pypi.python.org/packages/source/t/tgext.routes/tgext.routes-0.2.1.tar.gz"
+MD5SUM="94ee4e29e458fd8fbfd92c68245551d8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-routes python3-turbogears2"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-tgext.routes/slack-desc b/python/python3-tgext.routes/slack-desc
new file mode 100644
index 0000000000..1c40c9ccf7
--- /dev/null
+++ b/python/python3-tgext.routes/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-tgext.routes: python3-tgext.routes (Python Module)
+python3-tgext.routes:
+python3-tgext.routes: Provides Routes based dispatching for TurboGears2
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes:
+python3-tgext.routes: