summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.x86_64.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2011-09-21 22:44:36 -0500
committer Niels Horn <niels.horn@slackbuilds.org>2011-09-29 19:02:30 -0300
commit80dce55df22386bb46c295dacc45f1ad7f80f48b (patch)
tree84f23622f5af6e4d61cc9293d52faff939d5611b /python/python3/patches/python3.x86_64.diff
parent210f874c362b85f6d5af65a4cacdf5dd997adee7 (diff)
downloadslackbuilds-80dce55df22386bb46c295dacc45f1ad7f80f48b.tar.gz
slackbuilds-80dce55df22386bb46c295dacc45f1ad7f80f48b.tar.xz
python/python3: Updated for version 3.2.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python3/patches/python3.x86_64.diff')
-rw-r--r--python/python3/patches/python3.x86_64.diff46
1 files changed, 23 insertions, 23 deletions
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 44cc7797da..963f59cc33 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.2.1.orig/Lib/distutils/command/install.py Python-3.2.1/Lib/distutils/command/install.py
---- Python-3.2.1.orig/Lib/distutils/command/install.py 2011-07-09 09:58:46.000000000 +0300
-+++ Python-3.2.1/Lib/distutils/command/install.py 2011-07-11 13:24:36.929183098 +0300
-@@ -46,15 +46,15 @@
+diff -uar Python-3.2.2.orig/Lib/distutils/command/install.py Python-3.2.2/Lib/distutils/command/install.py
+--- Python-3.2.2.orig/Lib/distutils/command/install.py 2011-09-03 19:16:40.000000000 +0300
++++ Python-3.2.2/Lib/distutils/command/install.py 2011-09-05 23:16:30.986061070 +0300
+@@ -44,15 +44,15 @@
INSTALL_SCHEMES = {
'unix_prefix': {
@@ -21,10 +21,10 @@ diff -uar Python-3.2.1.orig/Lib/distutils/command/install.py Python-3.2.1/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.2.1.orig/Lib/distutils/sysconfig.py Python-3.2.1/Lib/distutils/sysconfig.py
---- Python-3.2.1.orig/Lib/distutils/sysconfig.py 2011-07-09 09:58:47.000000000 +0300
-+++ Python-3.2.1/Lib/distutils/sysconfig.py 2011-07-11 13:24:36.929183098 +0300
-@@ -125,7 +125,7 @@
+diff -uar Python-3.2.2.orig/Lib/distutils/sysconfig.py Python-3.2.2/Lib/distutils/sysconfig.py
+--- Python-3.2.2.orig/Lib/distutils/sysconfig.py 2011-09-03 19:16:40.000000000 +0300
++++ Python-3.2.2/Lib/distutils/sysconfig.py 2011-09-05 23:16:30.986061070 +0300
+@@ -123,7 +123,7 @@
if os.name == "posix":
libpython = os.path.join(prefix,
@@ -33,9 +33,9 @@ diff -uar Python-3.2.1.orig/Lib/distutils/sysconfig.py Python-3.2.1/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.2.1.orig/Lib/site.py Python-3.2.1/Lib/site.py
---- Python-3.2.1.orig/Lib/site.py 2011-07-09 09:58:49.000000000 +0300
-+++ Python-3.2.1/Lib/site.py 2011-07-11 13:24:36.930183090 +0300
+diff -uar Python-3.2.2.orig/Lib/site.py Python-3.2.2/Lib/site.py
+--- Python-3.2.2.orig/Lib/site.py 2011-09-03 19:16:42.000000000 +0300
++++ Python-3.2.2/Lib/site.py 2011-09-05 23:16:30.986061070 +0300
@@ -285,13 +285,13 @@
if sys.platform in ('os2emx', 'riscos'):
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
@@ -52,9 +52,9 @@ diff -uar Python-3.2.1.orig/Lib/site.py Python-3.2.1/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.2.1.orig/Lib/sysconfig.py Python-3.2.1/Lib/sysconfig.py
---- Python-3.2.1.orig/Lib/sysconfig.py 2011-07-09 09:58:49.000000000 +0300
-+++ Python-3.2.1/Lib/sysconfig.py 2011-07-11 13:24:36.930183090 +0300
+diff -uar Python-3.2.2.orig/Lib/sysconfig.py Python-3.2.2/Lib/sysconfig.py
+--- Python-3.2.2.orig/Lib/sysconfig.py 2011-09-03 19:16:42.000000000 +0300
++++ Python-3.2.2/Lib/sysconfig.py 2011-09-05 23:16:30.994061003 +0300
@@ -21,10 +21,10 @@
_INSTALL_SCHEMES = {
@@ -100,9 +100,9 @@ diff -uar Python-3.2.1.orig/Lib/sysconfig.py Python-3.2.1/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data' : '{userbase}',
-diff -uar Python-3.2.1.orig/Makefile.pre.in Python-3.2.1/Makefile.pre.in
---- Python-3.2.1.orig/Makefile.pre.in 2011-07-09 09:58:52.000000000 +0300
-+++ Python-3.2.1/Makefile.pre.in 2011-07-11 13:24:36.931183082 +0300
+diff -uar Python-3.2.2.orig/Makefile.pre.in Python-3.2.2/Makefile.pre.in
+--- Python-3.2.2.orig/Makefile.pre.in 2011-09-03 19:16:45.000000000 +0300
++++ Python-3.2.2/Makefile.pre.in 2011-09-05 23:16:30.994061003 +0300
@@ -106,7 +106,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@@ -112,9 +112,9 @@ diff -uar Python-3.2.1.orig/Makefile.pre.in Python-3.2.1/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.2.1.orig/Modules/getpath.c Python-3.2.1/Modules/getpath.c
---- Python-3.2.1.orig/Modules/getpath.c 2011-07-09 09:58:54.000000000 +0300
-+++ Python-3.2.1/Modules/getpath.c 2011-07-11 13:24:36.931183082 +0300
+diff -uar Python-3.2.2.orig/Modules/getpath.c Python-3.2.2/Modules/getpath.c
+--- Python-3.2.2.orig/Modules/getpath.c 2011-09-03 19:16:46.000000000 +0300
++++ Python-3.2.2/Modules/getpath.c 2011-09-05 23:16:30.995060994 +0300
@@ -122,8 +122,8 @@
#endif
@@ -153,9 +153,9 @@ diff -uar Python-3.2.1.orig/Modules/getpath.c Python-3.2.1/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.2.1.orig/setup.py Python-3.2.1/setup.py
---- Python-3.2.1.orig/setup.py 2011-07-09 09:58:56.000000000 +0300
-+++ Python-3.2.1/setup.py 2011-07-11 13:24:36.932183074 +0300
+diff -uar Python-3.2.2.orig/setup.py Python-3.2.2/setup.py
+--- Python-3.2.2.orig/setup.py 2011-09-03 19:16:50.000000000 +0300
++++ Python-3.2.2/setup.py 2011-09-05 23:16:30.995060994 +0300
@@ -396,7 +396,7 @@
# Ensure that /usr/local is always used, but the local build
# directories (i.e. '.' and 'Include') must be first. See issue