summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.x86_64.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2014-03-30 02:52:42 -0500
committer Erik Hanson <erik@slackbuilds.org>2014-04-12 13:59:48 -0500
commitd9a8bbf2e1c9302db876e15b3459b59c5f903db4 (patch)
treee65d52307fc6c52a4e0850a99b0f60f7d1320f43 /python/python3/patches/python3.x86_64.diff
parent10b1a40f6a8b0b59855dc5a8692bd926c5b83e7f (diff)
downloadslackbuilds-d9a8bbf2e1c9302db876e15b3459b59c5f903db4.tar.gz
slackbuilds-d9a8bbf2e1c9302db876e15b3459b59c5f903db4.tar.xz
python/python3: Updated for version 3.4.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python3/patches/python3.x86_64.diff')
-rw-r--r--python/python3/patches/python3.x86_64.diff108
1 files changed, 58 insertions, 50 deletions
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 5d5ce5f726..8fced1404b 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.3.3.orig/Lib/distutils/command/install.py Python-3.3.3/Lib/distutils/command/install.py
---- Python-3.3.3.orig/Lib/distutils/command/install.py 2013-11-17 09:22:30.000000000 +0200
-+++ Python-3.3.3/Lib/distutils/command/install.py 2013-12-29 13:48:10.102637141 +0200
+diff -uar Python-3.4.0.orig/Lib/distutils/command/install.py Python-3.4.0/Lib/distutils/command/install.py
+--- Python-3.4.0.orig/Lib/distutils/command/install.py 2014-03-17 04:31:29.000000000 +0200
++++ Python-3.4.0/Lib/distutils/command/install.py 2014-03-29 12:41:46.360404163 +0200
@@ -44,15 +44,15 @@
INSTALL_SCHEMES = {
@@ -21,10 +21,10 @@ diff -uar Python-3.3.3.orig/Lib/distutils/command/install.py Python-3.3.3/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.3.3.orig/Lib/distutils/sysconfig.py Python-3.3.3/Lib/distutils/sysconfig.py
---- Python-3.3.3.orig/Lib/distutils/sysconfig.py 2013-11-17 09:22:30.000000000 +0200
-+++ Python-3.3.3/Lib/distutils/sysconfig.py 2013-12-29 13:48:10.103637173 +0200
-@@ -144,7 +144,7 @@
+diff -uar Python-3.4.0.orig/Lib/distutils/sysconfig.py Python-3.4.0/Lib/distutils/sysconfig.py
+--- Python-3.4.0.orig/Lib/distutils/sysconfig.py 2014-03-17 04:31:29.000000000 +0200
++++ Python-3.4.0/Lib/distutils/sysconfig.py 2014-03-29 12:41:46.360404163 +0200
+@@ -142,7 +142,7 @@
if os.name == "posix":
libpython = os.path.join(prefix,
@@ -33,14 +33,13 @@ diff -uar Python-3.3.3.orig/Lib/distutils/sysconfig.py Python-3.3.3/Lib/distutil
if standard_lib:
return libpython
else:
-Only in Python-3.3.3/Lib/distutils: sysconfig.py.orig
-diff -uar Python-3.3.3.orig/Lib/site.py Python-3.3.3/Lib/site.py
---- Python-3.3.3.orig/Lib/site.py 2013-11-17 09:22:38.000000000 +0200
-+++ Python-3.3.3/Lib/site.py 2013-12-29 13:48:10.103637173 +0200
-@@ -303,13 +303,13 @@
- if sys.platform in ('os2emx', 'riscos'):
- sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
- elif os.sep == '/':
+diff -uar Python-3.4.0.orig/Lib/site.py Python-3.4.0/Lib/site.py
+--- Python-3.4.0.orig/Lib/site.py 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Lib/site.py 2014-03-29 12:45:39.339784221 +0200
+@@ -304,13 +304,13 @@
+ seen.add(prefix)
+
+ if os.sep == '/':
- sitepackages.append(os.path.join(prefix, "lib",
+ sitepackages.append(os.path.join(prefix, "lib64",
"python" + sys.version[:3],
@@ -53,10 +52,10 @@ diff -uar Python-3.3.3.orig/Lib/site.py Python-3.3.3/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.3.3.orig/Lib/sysconfig.py Python-3.3.3/Lib/sysconfig.py
---- Python-3.3.3.orig/Lib/sysconfig.py 2013-11-17 09:22:39.000000000 +0200
-+++ Python-3.3.3/Lib/sysconfig.py 2013-12-29 13:48:10.103637173 +0200
-@@ -21,10 +21,10 @@
+diff -uar Python-3.4.0.orig/Lib/sysconfig.py Python-3.4.0/Lib/sysconfig.py
+--- Python-3.4.0.orig/Lib/sysconfig.py 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Lib/sysconfig.py 2014-03-29 12:41:46.361404197 +0200
+@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
'posix_prefix': {
@@ -71,7 +70,7 @@ diff -uar Python-3.3.3.orig/Lib/sysconfig.py Python-3.3.3/Lib/sysconfig.py
'include':
'{installed_base}/include/python{py_version_short}{abiflags}',
'platinclude':
-@@ -33,10 +33,10 @@
+@@ -32,10 +32,10 @@
'data': '{base}',
},
'posix_home': {
@@ -86,7 +85,7 @@ diff -uar Python-3.3.3.orig/Lib/sysconfig.py Python-3.3.3/Lib/sysconfig.py
'include': '{installed_base}/include/python',
'platinclude': '{installed_base}/include/python',
'scripts': '{base}/bin',
-@@ -81,10 +81,10 @@
+@@ -61,10 +61,10 @@
'data': '{userbase}',
},
'posix_user': {
@@ -101,10 +100,10 @@ diff -uar Python-3.3.3.orig/Lib/sysconfig.py Python-3.3.3/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.3.3.orig/Lib/venv/__init__.py Python-3.3.3/Lib/venv/__init__.py
---- Python-3.3.3.orig/Lib/venv/__init__.py 2013-11-17 09:22:53.000000000 +0200
-+++ Python-3.3.3/Lib/venv/__init__.py 2013-12-29 13:48:10.103637173 +0200
-@@ -117,7 +117,7 @@
+diff -uar Python-3.4.0.orig/Lib/venv/__init__.py Python-3.4.0/Lib/venv/__init__.py
+--- Python-3.4.0.orig/Lib/venv/__init__.py 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Lib/venv/__init__.py 2014-03-29 12:41:46.361404197 +0200
+@@ -133,7 +133,7 @@
else:
binname = 'bin'
incpath = 'include'
@@ -113,10 +112,9 @@ diff -uar Python-3.3.3.orig/Lib/venv/__init__.py Python-3.3.3/Lib/venv/__init__.
context.inc_path = path = os.path.join(env_dir, incpath)
create_if_needed(path)
create_if_needed(libpath)
-Only in Python-3.3.3/Lib/venv: __init__.py.orig
-diff -uar Python-3.3.3.orig/Makefile.pre.in Python-3.3.3/Makefile.pre.in
---- Python-3.3.3.orig/Makefile.pre.in 2013-11-17 09:22:55.000000000 +0200
-+++ Python-3.3.3/Makefile.pre.in 2013-12-29 13:48:10.104637203 +0200
+diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
+--- Python-3.4.0.orig/Makefile.pre.in 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Makefile.pre.in 2014-03-29 12:41:46.361404197 +0200
@@ -115,7 +115,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@@ -126,11 +124,10 @@ diff -uar Python-3.3.3.orig/Makefile.pre.in Python-3.3.3/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-Only in Python-3.3.3: Makefile.pre.in.orig
-diff -uar Python-3.3.3.orig/Modules/getpath.c Python-3.3.3/Modules/getpath.c
---- Python-3.3.3.orig/Modules/getpath.c 2013-11-17 09:23:01.000000000 +0200
-+++ Python-3.3.3/Modules/getpath.c 2013-12-29 13:48:10.104637203 +0200
-@@ -122,8 +122,8 @@
+diff -uar Python-3.4.0.orig/Modules/getpath.c Python-3.4.0/Modules/getpath.c
+--- Python-3.4.0.orig/Modules/getpath.c 2014-03-17 04:31:31.000000000 +0200
++++ Python-3.4.0/Modules/getpath.c 2014-03-29 12:58:32.943849510 +0200
+@@ -118,8 +118,8 @@
#endif
#ifndef PYTHONPATH
@@ -141,16 +138,16 @@ diff -uar Python-3.3.3.orig/Modules/getpath.c Python-3.3.3/Modules/getpath.c
#endif
#ifndef LANDMARK
-@@ -135,7 +135,7 @@
- static wchar_t progpath[MAXPATHLEN+1];
- static wchar_t *module_search_path = NULL;
- static int module_search_path_malloced = 0;
--static wchar_t *lib_python = L"lib/python" VERSION;
-+static wchar_t *lib_python = L"lib64/python" VERSION;
+@@ -494,7 +494,7 @@
+ _pythonpath = _Py_char2wchar(PYTHONPATH, NULL);
+ _prefix = _Py_char2wchar(PREFIX, NULL);
+ _exec_prefix = _Py_char2wchar(EXEC_PREFIX, NULL);
+- lib_python = _Py_char2wchar("lib/python" VERSION, NULL);
++ lib_python = _Py_char2wchar("lib64/python" VERSION, NULL);
- static void
- reduce(wchar_t *dir)
-@@ -685,7 +685,7 @@
+ if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
+ Py_FatalError(
+@@ -683,7 +683,7 @@
}
else
wcsncpy(zip_path, _prefix, MAXPATHLEN);
@@ -168,11 +165,22 @@ diff -uar Python-3.3.3.orig/Modules/getpath.c Python-3.3.3/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-Only in Python-3.3.3/Modules: getpath.c.orig
-diff -uar Python-3.3.3.orig/setup.py Python-3.3.3/setup.py
---- Python-3.3.3.orig/setup.py 2013-11-17 09:23:09.000000000 +0200
-+++ Python-3.3.3/setup.py 2013-12-29 13:48:10.105637233 +0200
-@@ -439,7 +439,7 @@
+diff -uar Python-3.4.0.orig/configure Python-3.4.0/configure
+--- Python-3.4.0.orig/configure 2014-03-17 04:31:31.000000000 +0200
++++ Python-3.4.0/configure 2014-03-29 14:11:12.338969032 +0200
+@@ -13953,7 +13953,7 @@
+ $as_echo "$LDVERSION" >&6; }
+
+
+-LIBPL="${prefix}/lib/python${VERSION}/config-${LDVERSION}"
++LIBPL="${prefix}/lib64/python${VERSION}/config-${LDVERSION}"
+
+
+ # Check whether right shifting a negative integer extends the sign bit
+diff -uar Python-3.4.0.orig/setup.py Python-3.4.0/setup.py
+--- Python-3.4.0.orig/setup.py 2014-03-17 04:31:31.000000000 +0200
++++ Python-3.4.0/setup.py 2014-03-29 12:41:46.362404227 +0200
+@@ -445,7 +445,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
if not cross_compiling:
@@ -181,7 +189,7 @@ diff -uar Python-3.3.3.orig/setup.py Python-3.3.3/setup.py
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
-@@ -712,11 +712,11 @@
+@@ -722,11 +722,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -195,7 +203,7 @@ diff -uar Python-3.3.3.orig/setup.py Python-3.3.3/setup.py
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -753,8 +753,8 @@
+@@ -763,8 +763,8 @@
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,