summaryrefslogtreecommitdiffstats
path: root/python/python3/patches
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2012-11-20 12:03:52 -0600
committer Robby Workman <rworkman@slackbuilds.org>2012-11-20 12:03:52 -0600
commit6aba66e1724729ec21fe05a55369c7cd313d5a81 (patch)
tree1dd8cdfe56f85380568c853c59e9d5df73206717 /python/python3/patches
parent60da60a8430c73d7b91f119025be163bca7ea1a9 (diff)
downloadslackbuilds-6aba66e1724729ec21fe05a55369c7cd313d5a81.tar.gz
slackbuilds-6aba66e1724729ec21fe05a55369c7cd313d5a81.tar.xz
python/python3: Updated for version 3.3.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python3/patches')
-rw-r--r--python/python3/patches/python3.no-static-library.diff59
-rw-r--r--python/python3/patches/python3.x86_64.diff88
2 files changed, 103 insertions, 44 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
new file mode 100644
index 0000000000..dd7bdad6a1
--- /dev/null
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -0,0 +1,59 @@
+diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
+--- Python-3.3.0.orig/Makefile.pre.in 2012-09-29 11:00:41.000000000 +0300
++++ Python-3.3.0/Makefile.pre.in 2012-10-09 21:55:38.253943598 +0300
+@@ -463,7 +463,7 @@
+
+
+ # Build the interpreter
+-$(BUILDPYTHON): Modules/python.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
++$(BUILDPYTHON): Modules/python.o $(LDLIBRARY) $(PY3LIBRARY)
+ $(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
+
+ platform: $(BUILDPYTHON) $(SYSCONFIGDATA)
+@@ -479,18 +479,6 @@
+ $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' \
+ $(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
+
+-# Build static library
+-# avoid long command lines, same as LIBRARY_OBJS
+-$(LIBRARY): $(LIBRARY_OBJS)
+- -rm -f $@
+- $(AR) $(ARFLAGS) $@ Modules/getbuildinfo.o
+- $(AR) $(ARFLAGS) $@ $(PARSER_OBJS)
+- $(AR) $(ARFLAGS) $@ $(OBJECT_OBJS)
+- $(AR) $(ARFLAGS) $@ $(PYTHON_OBJS) Python/frozen.o
+- $(AR) $(ARFLAGS) $@ $(MODULE_OBJS) $(SIGNAL_OBJS)
+- $(AR) $(ARFLAGS) $@ $(MODOBJS)
+- $(RANLIB) $@
+-
+ libpython$(LDVERSION).so: $(LIBRARY_OBJS)
+ if test $(INSTSONAME) != $(LDLIBRARY); then \
+ $(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
+@@ -580,7 +568,7 @@
+ echo "-----------------------------------------------"; \
+ fi
+
+-Modules/_testembed: Modules/_testembed.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
++Modules/_testembed: Modules/_testembed.o $(LDLIBRARY) $(PY3LIBRARY)
+ $(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
+
+ ############################################################################
+@@ -1148,18 +1136,6 @@
+ else true; \
+ fi; \
+ done
+- @if test -d $(LIBRARY); then :; else \
+- if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
+- if test "$(SO)" = .dll; then \
+- $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+- else \
+- $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- fi; \
+- else \
+- echo Skip install of $(LIBRARY) - use make frameworkinstall; \
+- fi; \
+- fi
+ $(INSTALL_DATA) Modules/config.c $(DESTDIR)$(LIBPL)/config.c
+ $(INSTALL_DATA) Modules/python.o $(DESTDIR)$(LIBPL)/python.o
+ $(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 963f59cc33..d97019c544 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.2.2.orig/Lib/distutils/command/install.py Python-3.2.2/Lib/distutils/command/install.py
---- Python-3.2.2.orig/Lib/distutils/command/install.py 2011-09-03 19:16:40.000000000 +0300
-+++ Python-3.2.2/Lib/distutils/command/install.py 2011-09-05 23:16:30.986061070 +0300
+diff -uar Python-3.3.0.orig/Lib/distutils/command/install.py Python-3.3.0/Lib/distutils/command/install.py
+--- Python-3.3.0.orig/Lib/distutils/command/install.py 2012-09-29 11:00:27.000000000 +0300
++++ Python-3.3.0/Lib/distutils/command/install.py 2012-10-09 21:15:04.125445023 +0300
@@ -44,15 +44,15 @@
INSTALL_SCHEMES = {
@@ -21,10 +21,10 @@ diff -uar Python-3.2.2.orig/Lib/distutils/command/install.py Python-3.2.2/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.2.2.orig/Lib/distutils/sysconfig.py Python-3.2.2/Lib/distutils/sysconfig.py
---- Python-3.2.2.orig/Lib/distutils/sysconfig.py 2011-09-03 19:16:40.000000000 +0300
-+++ Python-3.2.2/Lib/distutils/sysconfig.py 2011-09-05 23:16:30.986061070 +0300
-@@ -123,7 +123,7 @@
+diff -uar Python-3.3.0.orig/Lib/distutils/sysconfig.py Python-3.3.0/Lib/distutils/sysconfig.py
+--- Python-3.3.0.orig/Lib/distutils/sysconfig.py 2012-09-29 11:00:28.000000000 +0300
++++ Python-3.3.0/Lib/distutils/sysconfig.py 2012-10-09 21:16:03.057946912 +0300
+@@ -140,7 +140,7 @@
if os.name == "posix":
libpython = os.path.join(prefix,
@@ -33,10 +33,10 @@ diff -uar Python-3.2.2.orig/Lib/distutils/sysconfig.py Python-3.2.2/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.2.2.orig/Lib/site.py Python-3.2.2/Lib/site.py
---- Python-3.2.2.orig/Lib/site.py 2011-09-03 19:16:42.000000000 +0300
-+++ Python-3.2.2/Lib/site.py 2011-09-05 23:16:30.986061070 +0300
-@@ -285,13 +285,13 @@
+diff -uar Python-3.3.0.orig/Lib/site.py Python-3.3.0/Lib/site.py
+--- Python-3.3.0.orig/Lib/site.py 2012-09-29 11:00:31.000000000 +0300
++++ Python-3.3.0/Lib/site.py 2012-10-09 21:17:48.131059160 +0300
+@@ -303,13 +303,13 @@
if sys.platform in ('os2emx', 'riscos'):
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
elif os.sep == '/':
@@ -52,41 +52,41 @@ diff -uar Python-3.2.2.orig/Lib/site.py Python-3.2.2/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.2.2.orig/Lib/sysconfig.py Python-3.2.2/Lib/sysconfig.py
---- Python-3.2.2.orig/Lib/sysconfig.py 2011-09-03 19:16:42.000000000 +0300
-+++ Python-3.2.2/Lib/sysconfig.py 2011-09-05 23:16:30.994061003 +0300
+diff -uar Python-3.3.0.orig/Lib/sysconfig.py Python-3.3.0/Lib/sysconfig.py
+--- Python-3.3.0.orig/Lib/sysconfig.py 2012-09-29 11:00:31.000000000 +0300
++++ Python-3.3.0/Lib/sysconfig.py 2012-10-09 21:24:26.697695600 +0300
@@ -21,10 +21,10 @@
_INSTALL_SCHEMES = {
'posix_prefix': {
-- 'stdlib': '{base}/lib/python{py_version_short}',
+- 'stdlib': '{installed_base}/lib/python{py_version_short}',
- 'platstdlib': '{platbase}/lib/python{py_version_short}',
- 'purelib': '{base}/lib/python{py_version_short}/site-packages',
- 'platlib': '{platbase}/lib/python{py_version_short}/site-packages',
-+ 'stdlib': '{base}/lib64/python{py_version_short}',
++ 'stdlib': '{installed_base}/lib64/python{py_version_short}',
+ 'platstdlib': '{platbase}/lib64/python{py_version_short}',
+ 'purelib': '{base}/lib64/python{py_version_short}/site-packages',
+ 'platlib': '{platbase}/lib64/python{py_version_short}/site-packages',
'include':
- '{base}/include/python{py_version_short}{abiflags}',
+ '{installed_base}/include/python{py_version_short}{abiflags}',
'platinclude':
@@ -33,10 +33,10 @@
'data': '{base}',
},
'posix_home': {
-- 'stdlib': '{base}/lib/python',
+- 'stdlib': '{installed_base}/lib/python',
- 'platstdlib': '{base}/lib/python',
- 'purelib': '{base}/lib/python',
- 'platlib': '{base}/lib/python',
-+ 'stdlib': '{base}/lib64/python',
++ 'stdlib': '{installed_base}/lib64/python',
+ 'platstdlib': '{base}/lib64/python',
+ 'purelib': '{base}/lib64/python',
+ 'platlib': '{base}/lib64/python',
- 'include': '{base}/include/python',
- 'platinclude': '{base}/include/python',
+ 'include': '{installed_base}/include/python',
+ 'platinclude': '{installed_base}/include/python',
'scripts': '{base}/bin',
@@ -81,10 +81,10 @@
- 'data' : '{userbase}',
+ 'data': '{userbase}',
},
'posix_user': {
- 'stdlib': '{userbase}/lib/python{py_version_short}',
@@ -99,11 +99,11 @@ diff -uar Python-3.2.2.orig/Lib/sysconfig.py Python-3.2.2/Lib/sysconfig.py
+ 'platlib': '{userbase}/lib64/python{py_version_short}/site-packages',
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
- 'data' : '{userbase}',
-diff -uar Python-3.2.2.orig/Makefile.pre.in Python-3.2.2/Makefile.pre.in
---- Python-3.2.2.orig/Makefile.pre.in 2011-09-03 19:16:45.000000000 +0300
-+++ Python-3.2.2/Makefile.pre.in 2011-09-05 23:16:30.994061003 +0300
-@@ -106,7 +106,7 @@
+ 'data': '{userbase}',
+diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
+--- Python-3.3.0.orig/Makefile.pre.in 2012-09-29 11:00:41.000000000 +0300
++++ Python-3.3.0/Makefile.pre.in 2012-10-09 21:26:05.949858929 +0300
+@@ -108,7 +108,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@@ -112,9 +112,9 @@ diff -uar Python-3.2.2.orig/Makefile.pre.in Python-3.2.2/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.2.2.orig/Modules/getpath.c Python-3.2.2/Modules/getpath.c
---- Python-3.2.2.orig/Modules/getpath.c 2011-09-03 19:16:46.000000000 +0300
-+++ Python-3.2.2/Modules/getpath.c 2011-09-05 23:16:30.995060994 +0300
+diff -uar Python-3.3.0.orig/Modules/getpath.c Python-3.3.0/Modules/getpath.c
+--- Python-3.3.0.orig/Modules/getpath.c 2012-09-29 11:00:45.000000000 +0300
++++ Python-3.3.0/Modules/getpath.c 2012-10-09 21:30:59.047390113 +0300
@@ -122,8 +122,8 @@
#endif
@@ -135,7 +135,7 @@ diff -uar Python-3.2.2.orig/Modules/getpath.c Python-3.2.2/Modules/getpath.c
static void
reduce(wchar_t *dir)
-@@ -583,7 +583,7 @@
+@@ -677,7 +677,7 @@
}
else
wcsncpy(zip_path, _prefix, MAXPATHLEN);
@@ -144,7 +144,7 @@ diff -uar Python-3.2.2.orig/Modules/getpath.c Python-3.2.2/Modules/getpath.c
bufsz = wcslen(zip_path); /* Replace "00" with version */
zip_path[bufsz - 6] = VERSION[0];
zip_path[bufsz - 5] = VERSION[2];
-@@ -593,7 +593,7 @@
+@@ -687,7 +687,7 @@
fprintf(stderr,
"Could not find platform dependent libraries <exec_prefix>\n");
wcsncpy(exec_prefix, _exec_prefix, MAXPATHLEN);
@@ -153,19 +153,19 @@ diff -uar Python-3.2.2.orig/Modules/getpath.c Python-3.2.2/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.2.2.orig/setup.py Python-3.2.2/setup.py
---- Python-3.2.2.orig/setup.py 2011-09-03 19:16:50.000000000 +0300
-+++ Python-3.2.2/setup.py 2011-09-05 23:16:30.995060994 +0300
-@@ -396,7 +396,7 @@
- # Ensure that /usr/local is always used, but the local build
+diff -uar Python-3.3.0.orig/setup.py Python-3.3.0/setup.py
+--- Python-3.3.0.orig/setup.py 2012-09-29 11:00:50.000000000 +0300
++++ Python-3.3.0/setup.py 2012-10-09 21:33:43.444006602 +0300
+@@ -459,7 +459,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
-- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
-+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
- self.add_multiarch_paths()
-
-@@ -643,11 +643,11 @@
+ if not cross_compiling:
+- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
++ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
+ add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+ # only change this for cross builds for 3.3, issues on Mageia
+ if cross_compiling:
+@@ -729,11 +729,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -179,7 +179,7 @@ diff -uar Python-3.2.2.orig/setup.py Python-3.2.2/setup.py
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -684,8 +684,8 @@
+@@ -770,8 +770,8 @@
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,