summaryrefslogtreecommitdiffstats
path: root/python/python3
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2013-04-27 00:19:56 -0500
committer Niels Horn <niels.horn@slackbuilds.org>2013-04-28 12:23:32 -0300
commit20b3ab52308a6cad97e72ab9835a3e3aa7f83c46 (patch)
tree0851f96712c26f81b2fdff6e3ff2e0a01eb6aeb2 /python/python3
parent513970f29c63c1056127ddaa25a0351cf33278bd (diff)
downloadslackbuilds-20b3ab52308a6cad97e72ab9835a3e3aa7f83c46.tar.gz
slackbuilds-20b3ab52308a6cad97e72ab9835a3e3aa7f83c46.tar.xz
python/python3: Updated for version 3.3.1.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python3')
-rw-r--r--python/python3/patches/python3.no-static-library.diff18
-rw-r--r--python/python3/python3.SlackBuild4
-rw-r--r--python/python3/python3.info10
3 files changed, 16 insertions, 16 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index dd7bdad6a1..c0e48bd9fb 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
---- Python-3.3.0.orig/Makefile.pre.in 2012-09-29 11:00:41.000000000 +0300
-+++ Python-3.3.0/Makefile.pre.in 2012-10-09 21:55:38.253943598 +0300
-@@ -463,7 +463,7 @@
+diff -uar Python-3.3.1.orig/Makefile.pre.in Python-3.3.1/Makefile.pre.in
+--- Python-3.3.1.orig/Makefile.pre.in 2013-04-06 10:41:48.000000000 +0300
++++ Python-3.3.1/Makefile.pre.in 2013-04-21 15:43:24.509324568 +0300
+@@ -471,7 +471,7 @@
# Build the interpreter
@@ -9,8 +9,8 @@ diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
+$(BUILDPYTHON): Modules/python.o $(LDLIBRARY) $(PY3LIBRARY)
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
- platform: $(BUILDPYTHON) $(SYSCONFIGDATA)
-@@ -479,18 +479,6 @@
+ platform: $(BUILDPYTHON) pybuilddir.txt
+@@ -495,18 +495,6 @@
$(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -580,7 +568,7 @@
+@@ -596,7 +584,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,13 +38,13 @@ diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1148,18 +1136,6 @@
+@@ -1191,18 +1179,6 @@
else true; \
fi; \
done
- @if test -d $(LIBRARY); then :; else \
- if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
-- if test "$(SO)" = .dll; then \
+- if test "$(SHLIB_SUFFIX)" = .dll; then \
- $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
- else \
- $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index da7bbe8c4d..945d6f0cfe 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python3
-VERSION=${VERSION:-3.3.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.3.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
diff --git a/python/python3/python3.info b/python/python3/python3.info
index c7cf075e69..6ba7888229 100644
--- a/python/python3/python3.info
+++ b/python/python3/python3.info
@@ -1,10 +1,10 @@
PRGNAM="python3"
-VERSION="3.3.0"
+VERSION="3.3.1"
HOMEPAGE="http://python.org/"
-DOWNLOAD="http://python.org/ftp/python/3.3.0/Python-3.3.0.tar.xz \
- http://python.org/ftp/python/doc/3.3.0/python-3.3.0-docs-html.tar.bz2"
-MD5SUM="2e7533b4009ac4adae62a7797a442e7a \
- d8de7264eb5b03b54044825b765324c7"
+DOWNLOAD="http://python.org/ftp/python/3.3.1/Python-3.3.1.tar.xz \
+ http://python.org/ftp/python/doc/3.3.1/python-3.3.1-docs-html.tar.bz2"
+MD5SUM="993232d9f4d9b4863cc1ec69a792e9cd \
+ e730def6cc4d6dddb076aae82661b6d6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""