summaryrefslogtreecommitdiffstats
path: root/python/pytz
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+SBo@gmail.com>2017-04-04 17:15:27 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-08 06:57:45 +0700
commit8121d70b22d4db4557ac2acda1911f1d4788d66d (patch)
tree6bbd8df63dc20277bde27ac14f070e40dd89eb2c /python/pytz
parentb998239fe408c84396d66c54a1b175630c1f5058 (diff)
downloadslackbuilds-8121d70b22d4db4557ac2acda1911f1d4788d66d.tar.gz
slackbuilds-8121d70b22d4db4557ac2acda1911f1d4788d66d.tar.xz
python/pytz: Add python3 support.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/pytz')
-rw-r--r--python/pytz/README5
-rw-r--r--python/pytz/pytz.SlackBuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/python/pytz/README b/python/pytz/README
index 354f8ea02c..fe43022964 100644
--- a/python/pytz/README
+++ b/python/pytz/README
@@ -3,3 +3,8 @@ accurate and cross platform timezone calculations using Python 2.3
or higher. It also solves the issue of ambiguous times at the end
of daylight savings, which you can read more about in the Python
Library Reference (datetime.tzinfo).
+
+python3 is an optional dependency. You need to set PYTHON3=yes,
+for example:
+
+ PYTHON3=yes ./pytz.SlackBuild
diff --git a/python/pytz/pytz.SlackBuild b/python/pytz/pytz.SlackBuild
index c9ee62ae6d..58f5207360 100644
--- a/python/pytz/pytz.SlackBuild
+++ b/python/pytz/pytz.SlackBuild
@@ -57,6 +57,11 @@ find -L . \
python setup.py install --root=$PKG
+# Install python3 bindings. Default is no.
+if [ "${PYTHON3:-no}" = "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true