summaryrefslogtreecommitdiffstats
path: root/python/pyutil/pyutil.SlackBuild
diff options
context:
space:
mode:
author Markus Reichelt <slackbuilds@mareichelt.de>2014-10-03 08:42:56 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-10-03 10:17:05 +0700
commit7c88bab532a5881ba979da87b3b31aed3eb974c7 (patch)
tree125468bc942c56c1d8b15ff40040a03eaf1a35d0 /python/pyutil/pyutil.SlackBuild
parent445719869e4b27756dfae0b067e1fa2c89e11427 (diff)
downloadslackbuilds-7c88bab532a5881ba979da87b3b31aed3eb974c7.tar.gz
slackbuilds-7c88bab532a5881ba979da87b3b31aed3eb974c7.tar.xz
python/pyutil: Updated for version 2.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyutil/pyutil.SlackBuild')
-rw-r--r--python/pyutil/pyutil.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/python/pyutil/pyutil.SlackBuild b/python/pyutil/pyutil.SlackBuild
index 7123a6d638..b97939852e 100644
--- a/python/pyutil/pyutil.SlackBuild
+++ b/python/pyutil/pyutil.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for pyutil.
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012-2013 Markus Reichelt, Stolberg (Rhld.), DE
+# Copyright 2012-2014 Markus Reichelt, Stolberg (Rhld.), DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=pyutil
-VERSION=${VERSION:-1.9.7}
+VERSION=${VERSION:-2.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,7 +72,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -80,9 +80,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING.GPL COPYING.TGPPL.html README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING* README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
#cleanup