summaryrefslogtreecommitdiffstats
path: root/python/pyxdg
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-05-07 23:33:34 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-05-07 23:33:34 +0700
commit7138036afd4f1d74f9da4905e605957ac9d15ce9 (patch)
tree0c66f124fa1481cb879e2ba7aa8b0e341f27f7a7 /python/pyxdg
parentab032da3b25846d2b3b6514a83cc3a71af2b9e18 (diff)
downloadslackbuilds-7138036afd4f1d74f9da4905e605957ac9d15ce9.tar.gz
slackbuilds-7138036afd4f1d74f9da4905e605957ac9d15ce9.tar.xz
python/pyxdg: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyxdg')
-rw-r--r--python/pyxdg/README4
-rw-r--r--python/pyxdg/pyxdg.SlackBuild5
2 files changed, 9 insertions, 0 deletions
diff --git a/python/pyxdg/README b/python/pyxdg/README
index 485a238ba1..6247c59ae0 100644
--- a/python/pyxdg/README
+++ b/python/pyxdg/README
@@ -1 +1,5 @@
PyXDG contains implementations of freedesktop.org standards in python.
+
+To install python3 bindings run the slackbuild with PYTHON3=yes.
+
+ # PYTHON3=yes ./pyxdg.SlackBuild
diff --git a/python/pyxdg/pyxdg.SlackBuild b/python/pyxdg/pyxdg.SlackBuild
index a1e16ec70d..f54fe8a8fd 100644
--- a/python/pyxdg/pyxdg.SlackBuild
+++ b/python/pyxdg/pyxdg.SlackBuild
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root $PKG
+# Install python3 bindings for pyxdg. Default is no.
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true