summaryrefslogtreecommitdiffstats
path: root/python/pyzmq
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-07-15 05:22:59 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-07-17 07:15:44 +0700
commit2bbc1ccb12dee51731084acc8ccd8956ac8f6f97 (patch)
tree1bb31a01e7022f6fe9b5f74382dd673138aa1dd7 /python/pyzmq
parenta2fe6c89f20edca1f0af33a037d91849271a0359 (diff)
downloadslackbuilds-2bbc1ccb12dee51731084acc8ccd8956ac8f6f97.tar.gz
slackbuilds-2bbc1ccb12dee51731084acc8ccd8956ac8f6f97.tar.xz
python/pyzmq: Updated for version 17.1.0.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python/pyzmq')
-rw-r--r--python/pyzmq/pyzmq.SlackBuild14
-rw-r--r--python/pyzmq/pyzmq.info6
2 files changed, 11 insertions, 9 deletions
diff --git a/python/pyzmq/pyzmq.SlackBuild b/python/pyzmq/pyzmq.SlackBuild
index 6903240fcb..c3c9e09b06 100644
--- a/python/pyzmq/pyzmq.SlackBuild
+++ b/python/pyzmq/pyzmq.SlackBuild
@@ -2,7 +2,7 @@
# SlackBuild script for PyZMQ
-# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2013-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyzmq
-VERSION=${VERSION:-17.0.0}
+VERSION=${VERSION:-17.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,16 +58,16 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-rm -rf $TMP/$PRGNAM-$VERSION
cd $TMP
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -75,7 +75,9 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS.md COPYING.BSD COPYING.LESSER README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS.md COPYING.BSD COPYING.LESSER README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pyzmq/pyzmq.info b/python/pyzmq/pyzmq.info
index b1e7596f27..8e2e671489 100644
--- a/python/pyzmq/pyzmq.info
+++ b/python/pyzmq/pyzmq.info
@@ -1,8 +1,8 @@
PRGNAM="pyzmq"
-VERSION="17.0.0"
+VERSION="17.1.0"
HOMEPAGE="https://github.com/zeromq/pyzmq"
-DOWNLOAD="https://github.com/zeromq/pyzmq/archive/v17.0.0.tar.gz"
-MD5SUM="29dcd90cd6e862ce9b4a0e5efd74ada8"
+DOWNLOAD="https://github.com/zeromq/pyzmq/archive/v17.1.0.tar.gz"
+MD5SUM="a9831a3fe1b043ac6fa379b48bbd5626"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="zeromq"