summaryrefslogtreecommitdiffstats
path: root/python/requirements-detector
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-15 16:28:48 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:20 +0700
commitf36971d3081f5737a7034bb83d549279366f24cb (patch)
tree5a19db14289919e5dde9aa1dc2034dcab6af4904 /python/requirements-detector
parent37d3ab125a367f58cb6c30080fc609ad39c2e564 (diff)
downloadslackbuilds-f36971d3081f5737a7034bb83d549279366f24cb.tar.gz
slackbuilds-f36971d3081f5737a7034bb83d549279366f24cb.tar.xz
python/requirements-detector: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/requirements-detector')
-rw-r--r--python/requirements-detector/requirements-detector.SlackBuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/requirements-detector/requirements-detector.SlackBuild b/python/requirements-detector/requirements-detector.SlackBuild
index d07df4f9e4..6975ae7dd0 100644
--- a/python/requirements-detector/requirements-detector.SlackBuild
+++ b/python/requirements-detector/requirements-detector.SlackBuild
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true