summaryrefslogtreecommitdiffstats
path: root/python/s3cmd
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2014-07-06 07:33:59 +0700
committer Robby Workman <rworkman@slackbuilds.org>2014-07-07 00:00:39 -0500
commit76c11975e2210f3a9b95ef5d17b7ac56ee93e33a (patch)
tree4fc0955a00e7209b3d10f08d6caaaa2dcdec03a0 /python/s3cmd
parent29e6753433908db1c3a5d14cabbdf15b23eb6e6f (diff)
downloadslackbuilds-76c11975e2210f3a9b95ef5d17b7ac56ee93e33a.tar.gz
slackbuilds-76c11975e2210f3a9b95ef5d17b7ac56ee93e33a.tar.xz
python/s3cmd: Updated for version 1.5.0_rc1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/s3cmd')
-rw-r--r--python/s3cmd/README4
-rw-r--r--python/s3cmd/s3cmd.SlackBuild30
-rw-r--r--python/s3cmd/s3cmd.info6
3 files changed, 29 insertions, 11 deletions
diff --git a/python/s3cmd/README b/python/s3cmd/README
index 97e8f25d43..b733f436cb 100644
--- a/python/s3cmd/README
+++ b/python/s3cmd/README
@@ -5,5 +5,5 @@ also ideal for scripts, automated backups triggered from cron, etc.
Optional: python-magic and pytz
Before s3cmd can be used it must first be set up. Run 's3cmd --configure' and
-enter in you access key and your secret key and follow the instructions. After
-this there will be a ~/.s3cfg file with your s3 credentials.
+enter in you access key and your secret key and follow the instructions. This
+will create ~/.s3cfg file with your s3 credentials.
diff --git a/python/s3cmd/s3cmd.SlackBuild b/python/s3cmd/s3cmd.SlackBuild
index c800b34eae..90a6e7ab06 100644
--- a/python/s3cmd/s3cmd.SlackBuild
+++ b/python/s3cmd/s3cmd.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for s3cmd
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2011-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=s3cmd
-VERSION=${VERSION:-1.5.0_beta1}
+VERSION=${VERSION:-1.5.0_rc1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -32,10 +50,10 @@ tar xvf $CWD/$PRGNAM-${VERSION/_/-}.tar.gz
cd $PRGNAM-${VERSION/_/-}
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -i 's|\(doc_path\)+"/s3cmd"|\1|' setup.py
diff --git a/python/s3cmd/s3cmd.info b/python/s3cmd/s3cmd.info
index 6950ff6b92..27cb7724ab 100644
--- a/python/s3cmd/s3cmd.info
+++ b/python/s3cmd/s3cmd.info
@@ -1,8 +1,8 @@
PRGNAM="s3cmd"
-VERSION="1.5.0_beta1"
+VERSION="1.5.0_rc1"
HOMEPAGE="http://s3tools.org/s3cmd"
-DOWNLOAD="http://downloads.sourceforge.net/s3tools/s3cmd-1.5.0-beta1.tar.gz"
-MD5SUM="14d651221d80948af3d065a62e9dd6c7"
+DOWNLOAD="http://downloads.sourceforge.net/s3tools/s3cmd-1.5.0-rc1.tar.gz"
+MD5SUM="eb5b461154b72890791c186ccdde13f0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""