summaryrefslogtreecommitdiffstats
path: root/python/secretstorage
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:24 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:29 +0700
commitcf3630ede674faa11740b54564732f9e6d6c66df (patch)
treef7ecafcbeee50aee6d88de62ee1ab74fd1c4f00d /python/secretstorage
parentdf72f8a75131a9e59f111d88f2eb9ce1317fd957 (diff)
downloadslackbuilds-cf3630ede674faa11740b54564732f9e6d6c66df.tar.gz
slackbuilds-cf3630ede674faa11740b54564732f9e6d6c66df.tar.xz
python/secretstorage: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/secretstorage')
-rw-r--r--python/secretstorage/README3
-rw-r--r--python/secretstorage/secretstorage.SlackBuild8
2 files changed, 4 insertions, 7 deletions
diff --git a/python/secretstorage/README b/python/secretstorage/README
index e798601294..b6b57a87ba 100644
--- a/python/secretstorage/README
+++ b/python/secretstorage/README
@@ -1 +1,2 @@
-This module provides a way for securely storing passwords and other secrets.
+This module provides a way for securely storing passwords and other
+secrets.
diff --git a/python/secretstorage/secretstorage.SlackBuild b/python/secretstorage/secretstorage.SlackBuild
index a30daa8119..6befe8b2ee 100644
--- a/python/secretstorage/secretstorage.SlackBuild
+++ b/python/secretstorage/secretstorage.SlackBuild
@@ -70,12 +70,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true