summaryrefslogtreecommitdiffstats
path: root/python/sphinxcontrib-applehelp
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-12-31 17:28:08 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-06 08:08:43 +0700
commit94f9c9db65fb626c27859152fda7f70da8deb611 (patch)
tree8b148d2233431164132f2e97d9d01c772b9f914d /python/sphinxcontrib-applehelp
parent3ad1e634cfff50fc68035d5f08b8d54f801b1000 (diff)
downloadslackbuilds-94f9c9db65fb626c27859152fda7f70da8deb611.tar.gz
slackbuilds-94f9c9db65fb626c27859152fda7f70da8deb611.tar.xz
python/sphinxcontrib-applehelp: Updated for version 1.0.7, new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/sphinxcontrib-applehelp')
-rw-r--r--python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.SlackBuild36
-rw-r--r--python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.info12
2 files changed, 18 insertions, 30 deletions
diff --git a/python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.SlackBuild b/python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.SlackBuild
index dbe44ce5c0..ba1697f443 100644
--- a/python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.SlackBuild
+++ b/python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for sphinxcontrib-applehelp
+# Copyright 2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240101 46and2: Updated version, new maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sphinxcontrib-applehelp
-VERSION=${VERSION:-1.0.2}
+SRCNAM=sphinxcontrib_applehelp
+VERSION=${VERSION:-1.0.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,36 +51,23 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.info b/python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.info
index 48a90ddd30..d31b2d03b5 100644
--- a/python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.info
+++ b/python/sphinxcontrib-applehelp/sphinxcontrib-applehelp.info
@@ -1,10 +1,10 @@
PRGNAM="sphinxcontrib-applehelp"
-VERSION="1.0.2"
+VERSION="1.0.7"
HOMEPAGE="https://github.com/sphinx-doc/sphinxcontrib-applehelp"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2.tar.gz"
-MD5SUM="3f2de7681e12dde031acee0497c3cc2b"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sphinxcontrib-applehelp/sphinxcontrib_applehelp-1.0.7.tar.gz"
+MD5SUM="660ede87eb89408a9989a740faab1675"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="python3-build"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"