summaryrefslogtreecommitdiffstats
path: root/python/stem
diff options
context:
space:
mode:
author Markus Reichelt <slackbuilds@mareichelt.de>2013-06-04 17:15:42 -0400
committer Robby Workman <rworkman@slackbuilds.org>2013-06-05 03:17:45 -0500
commit0f96596e5bf69f6ff5097edc7b01f35932ab63e7 (patch)
treeea96ab15c1dc2936e695cc88c22f705165119c13 /python/stem
parent328580f514324cbb23c5ed75509a134efe54efdb (diff)
downloadslackbuilds-0f96596e5bf69f6ff5097edc7b01f35932ab63e7.tar.gz
slackbuilds-0f96596e5bf69f6ff5097edc7b01f35932ab63e7.tar.xz
python/stem: Added (Python controller library for Tor)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python/stem')
-rw-r--r--python/stem/README6
-rw-r--r--python/stem/slack-desc19
-rw-r--r--python/stem/stem.SlackBuild86
-rw-r--r--python/stem/stem.info10
4 files changed, 121 insertions, 0 deletions
diff --git a/python/stem/README b/python/stem/README
new file mode 100644
index 0000000000..5ff10fc5aa
--- /dev/null
+++ b/python/stem/README
@@ -0,0 +1,6 @@
+stem is a Python controller library for Tor
+
+stem is compatible with python 2.6+ (including python 3)
+
+Having Tor installed is not required for building,
+but obviously it is for actually using this library.
diff --git a/python/stem/slack-desc b/python/stem/slack-desc
new file mode 100644
index 0000000000..1fc24e1f8b
--- /dev/null
+++ b/python/stem/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+stem: stem (Python controller library for Tor)
+stem:
+stem: This module is a Python controller library for Tor, and compatible
+stem: with python 2.6+ (including python 3)
+stem:
+stem: Homepage: https://stem.torproject.org/
+stem:
+stem:
+stem:
+stem:
+stem:
diff --git a/python/stem/stem.SlackBuild b/python/stem/stem.SlackBuild
new file mode 100644
index 0000000000..6020435048
--- /dev/null
+++ b/python/stem/stem.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for stem
+
+# Copyright 2013 Markus Reichelt, Stolberg (Rhld.), DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+
+PRGNAM=stem
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/stem/stem.info b/python/stem/stem.info
new file mode 100644
index 0000000000..5f31c3242a
--- /dev/null
+++ b/python/stem/stem.info
@@ -0,0 +1,10 @@
+PRGNAM="stem"
+VERSION="1.0.1"
+HOMEPAGE="https://stem.torproject.org/"
+DOWNLOAD="http://www.atagar.com/transfer/stem/stem-1.0.1.tar.bz2"
+MD5SUM="f21cac5ab6c8aca975f4bc1db73ff5e5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="tor"
+MAINTAINER="Markus Reichelt"
+EMAIL="slackbuilds@mareichelt.de"