summaryrefslogtreecommitdiffstats
path: root/python/subvertpy
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/subvertpy
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
slackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.xz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/subvertpy')
-rw-r--r--python/subvertpy/README3
-rw-r--r--python/subvertpy/slack-desc19
-rw-r--r--python/subvertpy/subvertpy.SlackBuild55
-rw-r--r--python/subvertpy/subvertpy.info10
4 files changed, 87 insertions, 0 deletions
diff --git a/python/subvertpy/README b/python/subvertpy/README
new file mode 100644
index 0000000000..7414605457
--- /dev/null
+++ b/python/subvertpy/README
@@ -0,0 +1,3 @@
+Alternative Python bindings for Subversion, split out from bzr-svn.
+The goal is to have complete, portable and "Pythonic" Python
+bindings.
diff --git a/python/subvertpy/slack-desc b/python/subvertpy/slack-desc
new file mode 100644
index 0000000000..7f6139b6db
--- /dev/null
+++ b/python/subvertpy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+subvertpy: subvertpy (Alternative Python bindings for Subversion)
+subvertpy:
+subvertpy: Alternative Python bindings for Subversion, split out from bzr-svn.
+subvertpy: The goal is to have complete, portable and "Pythonic" Python
+subvertpy: bindings.
+subvertpy:
+subvertpy: Homepage: http://samba.org/~jelmer/subvertpy/
+subvertpy:
+subvertpy:
+subvertpy:
+subvertpy:
diff --git a/python/subvertpy/subvertpy.SlackBuild b/python/subvertpy/subvertpy.SlackBuild
new file mode 100644
index 0000000000..2d6874be6c
--- /dev/null
+++ b/python/subvertpy/subvertpy.SlackBuild
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+# Slackware build script for subvertpy
+
+# Written by Mikko Värri (vmj@linuxbox.fi)
+# Public domain.
+
+PRGNAM=subvertpy
+VERSION=${VERSION:-0.7.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING INSTALL NEWS TODO examples $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/python/subvertpy/subvertpy.info b/python/subvertpy/subvertpy.info
new file mode 100644
index 0000000000..17f39a61e1
--- /dev/null
+++ b/python/subvertpy/subvertpy.info
@@ -0,0 +1,10 @@
+PRGNAM="subvertpy"
+VERSION="0.7.5"
+HOMEPAGE="http://samba.org/~jelmer/subvertpy/"
+DOWNLOAD="http://samba.org/~jelmer/subvertpy/subvertpy-0.7.5.tar.gz"
+MD5SUM="2e84979c7380a396d6beec278f2d6104"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikko Värri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="dsomero,Niels Horn"