summaryrefslogtreecommitdiffstats
path: root/python/tweepy/update_req_for_pip6.patch
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2015-03-10 14:53:16 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-14 16:55:54 +0700
commit59db74dcd4c6eff27a42b71d596662f52c3fa8d4 (patch)
treef182fd98bc9ede95f4fd9d1fb1594de144c38d96 /python/tweepy/update_req_for_pip6.patch
parent0e3fb4668163e3bba8a17cce2677a95018d0ad65 (diff)
downloadslackbuilds-59db74dcd4c6eff27a42b71d596662f52c3fa8d4.tar.gz
slackbuilds-59db74dcd4c6eff27a42b71d596662f52c3fa8d4.tar.xz
python/tweepy: Updated for version 3.1.0.
Added the new deps pip, requests-oauthlib and six Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/tweepy/update_req_for_pip6.patch')
-rw-r--r--python/tweepy/update_req_for_pip6.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/python/tweepy/update_req_for_pip6.patch b/python/tweepy/update_req_for_pip6.patch
new file mode 100644
index 0000000000..0214819549
--- /dev/null
+++ b/python/tweepy/update_req_for_pip6.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/setup.py
+index 2de2d05..3b3b807 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,6 +1,6 @@
+ #!/usr/bin/env python
+ #from distutils.core import setup
+-import re
++import re, uuid
+ from setuptools import setup, find_packages
+ from pip.req import parse_requirements
+
+@@ -14,7 +14,7 @@ if mo:
+ else:
+ raise RuntimeError("Unable to find version string in %s." % (VERSIONFILE,))
+
+-install_reqs = parse_requirements('requirements.txt')
++install_reqs = parse_requirements('requirements.txt', session=uuid.uuid1())
+ reqs = [str(req.req) for req in install_reqs]
+
+ setup(name="tweepy",