summaryrefslogtreecommitdiffstats
path: root/python/virtualenv-clone
diff options
context:
space:
mode:
author vvoody <vvoodywang@gmail.com>2013-11-27 23:36:59 -0600
committer Robby Workman <rworkman@slackbuilds.org>2013-11-27 23:36:59 -0600
commit2c82c4348e78351f12329ecc80916b87a3126281 (patch)
tree269057aacd6958b283b89616c1f4c91c4192e21b /python/virtualenv-clone
parent1f6895c099453a69d67d74a47769411e8aa75bbf (diff)
downloadslackbuilds-2c82c4348e78351f12329ecc80916b87a3126281.tar.gz
slackbuilds-2c82c4348e78351f12329ecc80916b87a3126281.tar.xz
python/virtualenv-clone: Added (virtualenv cloning script)
This is a runtime dependency of virtualenvwrapper. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/virtualenv-clone')
-rw-r--r--python/virtualenv-clone/README1
-rw-r--r--python/virtualenv-clone/slack-desc19
-rw-r--r--python/virtualenv-clone/virtualenv-clone.SlackBuild86
-rw-r--r--python/virtualenv-clone/virtualenv-clone.info10
4 files changed, 116 insertions, 0 deletions
diff --git a/python/virtualenv-clone/README b/python/virtualenv-clone/README
new file mode 100644
index 0000000000..9cb39e8785
--- /dev/null
+++ b/python/virtualenv-clone/README
@@ -0,0 +1 @@
+virtualenv-clone is a script for cloning a non-relocatable virtualenv.
diff --git a/python/virtualenv-clone/slack-desc b/python/virtualenv-clone/slack-desc
new file mode 100644
index 0000000000..dc2fe1daf5
--- /dev/null
+++ b/python/virtualenv-clone/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+virtualenv-clone: virtualenv-clone (virtualenv cloning script)
+virtualenv-clone:
+virtualenv-clone: virtualenv-clone is a script for cloning a non-relocatable virtualenv.
+virtualenv-clone:
+virtualenv-clone: Homepage: https://github.com/edwardgeorge/virtualenv-clone
+virtualenv-clone:
+virtualenv-clone:
+virtualenv-clone:
+virtualenv-clone:
+virtualenv-clone:
+virtualenv-clone:
diff --git a/python/virtualenv-clone/virtualenv-clone.SlackBuild b/python/virtualenv-clone/virtualenv-clone.SlackBuild
new file mode 100644
index 0000000000..bc32731219
--- /dev/null
+++ b/python/virtualenv-clone/virtualenv-clone.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for virtualenv-clone
+
+# Copyright <2013> <vvoody> <Shanghai>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=virtualenv-clone
+VERSION=${VERSION:-0.2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/virtualenv-clone/virtualenv-clone.info b/python/virtualenv-clone/virtualenv-clone.info
new file mode 100644
index 0000000000..7ac8c8c8ae
--- /dev/null
+++ b/python/virtualenv-clone/virtualenv-clone.info
@@ -0,0 +1,10 @@
+PRGNAM="virtualenvwrapper"
+VERSION="0.2.4"
+HOMEPAGE="https://github.com/edwardgeorge/virtualenv-clone"
+DOWNLOAD="https://pypi.python.org/packages/source/v/virtualenv-clone/virtualenv-clone-0.2.4.tar.gz"
+MD5SUM="71168b975eaaa91e65559bcc79290b3b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="vvoody"
+EMAIL="vvoodywang@gmail.com"