summaryrefslogtreecommitdiffstats
path: root/python/werkzeug
diff options
context:
space:
mode:
author Dominik Drobek <dominik.drobek@o2.pl>2019-03-17 15:48:48 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-03-20 21:00:36 +0700
commit1648ef09979955a619383f8a1ee91ce290a503b4 (patch)
treecd698eabc3ec768cd1ca223ec3116ae76147dfca /python/werkzeug
parent87ada4b9ca4404a24cf7a59400482b2b11728ae2 (diff)
downloadslackbuilds-1648ef09979955a619383f8a1ee91ce290a503b4.tar.gz
slackbuilds-1648ef09979955a619383f8a1ee91ce290a503b4.tar.xz
python/werkzeug: enable Python3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/werkzeug')
-rw-r--r--python/werkzeug/werkzeug.SlackBuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/python/werkzeug/werkzeug.SlackBuild b/python/werkzeug/werkzeug.SlackBuild
index a80c334d62..3f9aacdc9b 100644
--- a/python/werkzeug/werkzeug.SlackBuild
+++ b/python/werkzeug/werkzeug.SlackBuild
@@ -2,8 +2,8 @@
# Slackware build script for werkzeug
-# Copyright 2018 Dominik Drobek <dominik.drobek (at) o2.pl>
# Copyright 2013 Mohamed LYAHYAOUI <mlyahyaoui@gmail.com>
+# Copyright 2018, 2019 Dominik Drobek <dominik.drobek (at) o2.pl>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
PRGNAM=werkzeug
SRCNAM=Werkzeug
VERSION=${VERSION:-0.14.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,10 +71,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build
-
python setup.py install --root $PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true