summaryrefslogtreecommitdiffstats
path: root/python/xopen
diff options
context:
space:
mode:
author Petar Petrov <slackalaxy@gmail.com>2017-04-17 00:09:04 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-22 08:10:41 +0700
commita3131df8a7ec07516ae970fc348839b55fbad353 (patch)
treef4240d5f0dd6328ecdc423bd561a95a4f2d5da1b /python/xopen
parente2d2502ea363eca94a2342ace1fb713c1d89f46c (diff)
downloadslackbuilds-a3131df8a7ec07516ae970fc348839b55fbad353.tar.gz
slackbuilds-a3131df8a7ec07516ae970fc348839b55fbad353.tar.xz
python/xopen: Added (xopen function for compressed files).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/xopen')
-rw-r--r--python/xopen/README12
-rw-r--r--python/xopen/slack-desc19
-rw-r--r--python/xopen/xopen.SlackBuild85
-rw-r--r--python/xopen/xopen.info10
4 files changed, 126 insertions, 0 deletions
diff --git a/python/xopen/README b/python/xopen/README
new file mode 100644
index 0000000000..97bf8546ee
--- /dev/null
+++ b/python/xopen/README
@@ -0,0 +1,12 @@
+This Python module provides a xopen function that works like the built-
+in open function, but can also deal with compressed files. Supported
+compression formats are gzip, bzip2 and xz. They are automatically
+recognized by their file extensions .gz, .bz2 or .xz.
+
+The focus is on being as efficient as possible on all supported Python
+versions. For example, simply using gzip.open is slow in older Pythons,
+and it is a lot faster to use a gzip subprocess.
+
+This module has originally been developed as part of the cutadapt tool
+that is used in bioinformatics to manipulate sequencing data. It has
+been in successful use within that software for a few years.
diff --git a/python/xopen/slack-desc b/python/xopen/slack-desc
new file mode 100644
index 0000000000..3cc87caeb2
--- /dev/null
+++ b/python/xopen/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xopen: xopen (A xopen function that can deal with compressed files)
+xopen:
+xopen: This Python module provides a xopen function that works like the
+xopen: built-in open function, but can also deal with compressed files.
+xopen: Supported compression formats are gzip, bzip2 and xz. They are
+xopen: automatically recognized by their file extensions .gz, .bz2 or
+xopen: .xz.
+xopen:
+xopen:
+xopen:
+xopen:
diff --git a/python/xopen/xopen.SlackBuild b/python/xopen/xopen.SlackBuild
new file mode 100644
index 0000000000..3966c454cb
--- /dev/null
+++ b/python/xopen/xopen.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for xopen
+
+# Copyright 2017 Petar Petrov slackalaxy@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=xopen
+VERSION=${VERSION:-0.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/xopen/xopen.info b/python/xopen/xopen.info
new file mode 100644
index 0000000000..fbc9d9bf3c
--- /dev/null
+++ b/python/xopen/xopen.info
@@ -0,0 +1,10 @@
+PRGNAM="xopen"
+VERSION="0.1.1"
+HOMEPAGE="https://pypi.python.org/pypi/xopen"
+DOWNLOAD="https://pypi.python.org/packages/9a/b7/8906d6b2c4f874c0aacc676709a3d533362ac93bebc4a656c9df19421c9b/xopen-0.1.1.tar.gz"
+MD5SUM="4e0e955546ee6bee4ea736b54623a671"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Petar Petrov"
+EMAIL="slackalaxy@gmail.com"