summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Prof. HORSTMANN <wmh@eipg.fr>2020-05-15 23:19:18 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-05-16 08:44:12 +0700
commit0d85ab9558a326a4258527d5a168aceb0ed9140f (patch)
treef7398e724e100e5da4d12c4757770b613225d416 /python
parent5da8c8e1d68813dd1412ca6b8b6b079aa65d6ce3 (diff)
downloadslackbuilds-0d85ab9558a326a4258527d5a168aceb0ed9140f.tar.gz
slackbuilds-0d85ab9558a326a4258527d5a168aceb0ed9140f.tar.xz
python/sphinx-rtd-theme: Added (decorator)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/sphinx-rtd-theme/README7
-rw-r--r--python/sphinx-rtd-theme/slack-desc19
-rw-r--r--python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild78
-rw-r--r--python/sphinx-rtd-theme/sphinx-rtd-theme.info10
4 files changed, 114 insertions, 0 deletions
diff --git a/python/sphinx-rtd-theme/README b/python/sphinx-rtd-theme/README
new file mode 100644
index 0000000000..9e27b7a33d
--- /dev/null
+++ b/python/sphinx-rtd-theme/README
@@ -0,0 +1,7 @@
+The sphinx_rtd_theme is a sphinx theme designed to look modern and be
+mobile-friendly.
+
+This theme is primarily focused to be used on readthedocs.org but can work with
+your own sphinx projects.
+
+To read more and see a working demo head over to readthedocs.org.
diff --git a/python/sphinx-rtd-theme/slack-desc b/python/sphinx-rtd-theme/slack-desc
new file mode 100644
index 0000000000..b8e2b0cd25
--- /dev/null
+++ b/python/sphinx-rtd-theme/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+sphinx-rtd-theme: sphinx-rtd-theme (decorator for caching properties in classes)
+sphinx-rtd-theme:
+sphinx-rtd-theme: The sphinx_rtd_theme is a sphinx theme designed to look modern and be
+sphinx-rtd-theme: mobile-friendly.
+sphinx-rtd-theme:
+sphinx-rtd-theme:
+sphinx-rtd-theme: Homepage: https://pypi.org/project/sphinx-rtd-theme
+sphinx-rtd-theme:
+sphinx-rtd-theme:
+sphinx-rtd-theme:
+sphinx-rtd-theme:
diff --git a/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild b/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild
new file mode 100644
index 0000000000..e1937e1790
--- /dev/null
+++ b/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# SlackBuild build script for sphinx_rtd_theme
+
+# Copyright (c) 2000-2020 Prof. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=sphinx-rtd-theme
+PKGNAM=sphinx_rtd_theme
+VERSION=${VERSION:-0.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PKGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+ # Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+fi
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/sphinx-rtd-theme/sphinx-rtd-theme.info b/python/sphinx-rtd-theme/sphinx-rtd-theme.info
new file mode 100644
index 0000000000..5b7649d034
--- /dev/null
+++ b/python/sphinx-rtd-theme/sphinx-rtd-theme.info
@@ -0,0 +1,10 @@
+PRGNAM="sphinx-rtd-theme"
+VERSION="0.4.3"
+HOMEPAGE="https://pypi.org/project/sphinx-rtd-theme"
+DOWNLOAD="https://files.pythonhosted.org/packages/ed/73/7e550d6e4cf9f78a0e0b60b9d93dba295389c3d271c034bf2ea3463a79f9/sphinx_rtd_theme-0.4.3.tar.gz"
+MD5SUM="6c50f30bc39046f497d336039a0c13fa"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Prof. HORSTMANN"
+EMAIL="wmh@eipg.fr"