summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2019-05-09 23:54:48 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-05-09 23:54:48 +0700
commit319f092748a9d8c8c4ba76ba9e2bed36e814f809 (patch)
treeed27d6f289be033b35a8a7ec76a61481b899d615 /python
parent74756ed3f19fab2eec16b963e092d4b454a1a44a (diff)
downloadslackbuilds-319f092748a9d8c8c4ba76ba9e2bed36e814f809.tar.gz
slackbuilds-319f092748a9d8c8c4ba76ba9e2bed36e814f809.tar.xz
python/python3-defusedxml: Updated for version 0.6.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-defusedxml/README6
-rw-r--r--python/python3-defusedxml/python3-defusedxml.SlackBuild60
-rw-r--r--python/python3-defusedxml/python3-defusedxml.info12
-rw-r--r--python/python3-defusedxml/slack-desc10
4 files changed, 47 insertions, 41 deletions
diff --git a/python/python3-defusedxml/README b/python/python3-defusedxml/README
index 252fe89b4b..b0d4050e0c 100644
--- a/python/python3-defusedxml/README
+++ b/python/python3-defusedxml/README
@@ -1 +1,5 @@
-XML bomb protection for Python stdlib modules.
+The defusedxml package contains several Python-only workarounds and fixes for
+denial of service and other vulnerabilities in Python’s XML libraries. In order
+to benefit from the protection you just have to import and use the listed
+functions or classes from the right defusedxml module instead of the original
+module.
diff --git a/python/python3-defusedxml/python3-defusedxml.SlackBuild b/python/python3-defusedxml/python3-defusedxml.SlackBuild
index a5bdd82b6f..f87af3a58e 100644
--- a/python/python3-defusedxml/python3-defusedxml.SlackBuild
+++ b/python/python3-defusedxml/python3-defusedxml.SlackBuild
@@ -1,39 +1,36 @@
#!/bin/sh
-# Slackware build script for "python3-defusedxml".
+# Slackware build script for python3-defusedxml
-# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
+# Copyright 2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python3-defusedxml
-SRCNAM=tiran-defusedxml
-REV=${REV:-f6b0e619a6c8}
-VERSION=${VERSION:-0.4.1}
+SRCNAM=defusedxml
+PRGNAM=python3-$SRCNAM
+VERSION=${VERSION:-0.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -44,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -63,9 +60,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$REV
-tar xvf $CWD/v$VERSION.tar.bz2 || tar xvf $CWD/$SRCNAM-$REV.tar.bz2
-cd $SRCNAM-$REV
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -75,8 +72,13 @@ find -L . \
python3 setup.py install --root=$PKG
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.txt LICENSE README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.txt LICENSE README.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-defusedxml/python3-defusedxml.info b/python/python3-defusedxml/python3-defusedxml.info
index bb161da5d9..8481db2d8e 100644
--- a/python/python3-defusedxml/python3-defusedxml.info
+++ b/python/python3-defusedxml/python3-defusedxml.info
@@ -1,10 +1,10 @@
PRGNAM="python3-defusedxml"
-VERSION="0.4.1"
-HOMEPAGE="https://bitbucket.org/tiran/defusedxml/"
-DOWNLOAD="https://bitbucket.org/tiran/defusedxml/get/v0.4.1.tar.bz2"
-MD5SUM="f84ac91c1b82860ec329aebeb5484462"
+VERSION="0.6.0"
+HOMEPAGE="https://github.com/tiran/defusedxml"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/d/defusedxml/defusedxml-0.6.0.tar.gz"
+MD5SUM="a59741f675c4cba649de40a99f732897"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3"
-MAINTAINER="Marcel Saegebarth"
-EMAIL="marc@mos6581.de"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-defusedxml/slack-desc b/python/python3-defusedxml/slack-desc
index d1404e4351..a385345a99 100644
--- a/python/python3-defusedxml/slack-desc
+++ b/python/python3-defusedxml/slack-desc
@@ -8,11 +8,11 @@
|-----handy-ruler------------------------------------------------------|
python3-defusedxml: python3-defusedxml (XML bomb protection for Python stdlib modules)
python3-defusedxml:
-python3-defusedxml: XML bomb protection for Python stdlib modules.
-python3-defusedxml:
-python3-defusedxml: Homepage: https://bitbucket.org/tiran/defusedxml/
-python3-defusedxml:
-python3-defusedxml:
+python3-defusedxml: The defusedxml package contains several Python-only workarounds and
+python3-defusedxml: fixes for denial of service and other vulnerabilities in Python's
+python3-defusedxml: XML libraries. In order to benefit from the protection you just have
+python3-defusedxml: to import and use the listed functions or classes from the right
+python3-defusedxml: defusedxml module instead of the original module.
python3-defusedxml:
python3-defusedxml:
python3-defusedxml: