summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Fernando Lopez Jr <fernando.lopezjr@gmail.com>2019-06-29 06:46:59 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-06-29 06:46:59 +0700
commit420135de0c0e23c6050cf8959aa3c20283057637 (patch)
tree8448f89852b88fb3a249e6788778dc432bda2e47 /python
parent0ee5bfc1065ae049cb183faa6e91243dd6570943 (diff)
downloadslackbuilds-420135de0c0e23c6050cf8959aa3c20283057637.tar.gz
slackbuilds-420135de0c0e23c6050cf8959aa3c20283057637.tar.xz
python/ofxparse: Added (OFX parser).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/ofxparse/README9
-rw-r--r--python/ofxparse/ofxparse.SlackBuild73
-rw-r--r--python/ofxparse/ofxparse.info10
-rw-r--r--python/ofxparse/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/python/ofxparse/README b/python/ofxparse/README
new file mode 100644
index 0000000000..647953feb0
--- /dev/null
+++ b/python/ofxparse/README
@@ -0,0 +1,9 @@
+ofxparse is a parser for Open Financial Exchange (.ofx) format
+files. OFX files are available from almost any online banking
+site, so they work well if you want to pull together your finances
+from multiple sources. Online trading accounts also provide account
+statements in OFX files.
+
+There are three different types of OFX files, called BankAccount,
+CreditAccount and InvestmentAccount files. This library has been
+tested with real-world samples of all three types.
diff --git a/python/ofxparse/ofxparse.SlackBuild b/python/ofxparse/ofxparse.SlackBuild
new file mode 100644
index 0000000000..6a1e4b5b42
--- /dev/null
+++ b/python/ofxparse/ofxparse.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for ofxparse
+
+# Copyright 2019 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ofxparse
+VERSION=${VERSION:-0.20}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/ofxparse/ofxparse.info b/python/ofxparse/ofxparse.info
new file mode 100644
index 0000000000..f53f072a0b
--- /dev/null
+++ b/python/ofxparse/ofxparse.info
@@ -0,0 +1,10 @@
+PRGNAM="ofxparse"
+VERSION="0.20"
+HOMEPAGE="https://pypi.org/project/ofxparse/"
+DOWNLOAD="https://files.pythonhosted.org/packages/07/ab/22faf6348652e9ac662b594c35ee9de1dba76b5adcad94a143d317377138/ofxparse-0.20.tar.gz"
+MD5SUM="a3daf82edc5fd1ebee560264a7cdf5e7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/python/ofxparse/slack-desc b/python/ofxparse/slack-desc
new file mode 100644
index 0000000000..e629da73eb
--- /dev/null
+++ b/python/ofxparse/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ofxparse: ofxparse (OFX parser)
+ofxparse:
+ofxparse: ofxparse is a parser for Open Financial Exchange (.ofx) format files.
+ofxparse: OFX files are available from almost any online banking site and online
+ofxparse: trading accounts as well.
+ofxparse:
+ofxparse: There are three different types of OFX files, called BankAccount,
+ofxparse: CreditAccount and InvestmentAccount files. This library has been
+ofxparse: tested with real-world samples of all three types.
+ofxparse:
+ofxparse: