summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Marcel Saegebarth <marc@mos6581.de>2015-02-07 06:18:44 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-07 06:18:44 +0700
commit432b92eaf8ff4c7cf5d16567bfb944990d05d878 (patch)
tree0f7b3922b90ec0494f7b9ccbd0d22fa7caed0e1e /python
parentb35e7fc4becc290f141354e09870dfb480260a9a (diff)
downloadslackbuilds-432b92eaf8ff4c7cf5d16567bfb944990d05d878.tar.gz
slackbuilds-432b92eaf8ff4c7cf5d16567bfb944990d05d878.tar.xz
python/python-memcached: Added (Python client for memached).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-memcached/README4
-rw-r--r--python/python-memcached/python-memcached.SlackBuild84
-rw-r--r--python/python-memcached/python-memcached.info10
-rw-r--r--python/python-memcached/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/python-memcached/README b/python/python-memcached/README
new file mode 100644
index 0000000000..80f55a7514
--- /dev/null
+++ b/python/python-memcached/README
@@ -0,0 +1,4 @@
+This software is a 100% Python interface to the memcached memory
+cache daemon. It is the client side software which allows storing
+values in one or more, possibly remote, memcached servers. Search
+google for memcached for more information.
diff --git a/python/python-memcached/python-memcached.SlackBuild b/python/python-memcached/python-memcached.SlackBuild
new file mode 100644
index 0000000000..4aa9ccbcad
--- /dev/null
+++ b/python/python-memcached/python-memcached.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for "python-memcached".
+
+# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-memcached
+VERSION=${VERSION:-1.53}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-release-$VERSION
+tar xvf $CWD/release-$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-release-$VERSION.tar.gz
+cd $PRGNAM-release-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog PSF.LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-memcached/python-memcached.info b/python/python-memcached/python-memcached.info
new file mode 100644
index 0000000000..25c93836a0
--- /dev/null
+++ b/python/python-memcached/python-memcached.info
@@ -0,0 +1,10 @@
+PRGNAM="python-memcached"
+VERSION="1.53"
+HOMEPAGE="https://github.com/linsomniac/python-memcached/"
+DOWNLOAD="https://github.com/linsomniac/python-memcached/archive/release-1.53.tar.gz"
+MD5SUM="99d19b23bb8a77f66a2f4ea83adb8e46"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/python/python-memcached/slack-desc b/python/python-memcached/slack-desc
new file mode 100644
index 0000000000..f089e21945
--- /dev/null
+++ b/python/python-memcached/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-memcached: python-memcached (Python client for memached)
+python-memcached:
+python-memcached: This software is a 100% Python interface to the memcached memory
+python-memcached: cache daemon. It is the client side software which allows storing
+python-memcached: values in one or more, possibly remote, memcached servers. Search
+python-memcached: google for memcached for more information.
+python-memcached:
+python-memcached: Homepage: https://github.com/linsomniac/python-memcached
+python-memcached:
+python-memcached:
+python-memcached: