summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2018-11-02 12:18:57 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-03 07:46:40 +0700
commit514e76fd62ec642188bbc42d527b29447094913b (patch)
treedd7d4ed795acbfc46fcae0642c06df6d6459f57c /python
parent62e62a903653430853d933e89295a5aca02a3003 (diff)
downloadslackbuilds-514e76fd62ec642188bbc42d527b29447094913b.tar.gz
slackbuilds-514e76fd62ec642188bbc42d527b29447094913b.tar.xz
python/phply: Fix collision, script update.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/phply/README3
-rw-r--r--python/phply/phply.SlackBuild14
-rw-r--r--python/phply/phply.info2
3 files changed, 12 insertions, 7 deletions
diff --git a/python/phply/README b/python/phply/README
index b46d11c04b..d500d137a4 100644
--- a/python/phply/README
+++ b/python/phply/README
@@ -5,8 +5,5 @@ See README.Slackware for some usage notes.
A Note on Dependencies:
-Nose is only required to run the python test suite. It is not a
-run-time dependency and can be safely removed after phply is built.
-
The python library simplejson is an optional dependency. phply ships with a
script php2json.py in /usr/doc/phply-$VERSION/tools that requires it.
diff --git a/python/phply/phply.SlackBuild b/python/phply/phply.SlackBuild
index f18e87bb57..d708a7c5ec 100644
--- a/python/phply/phply.SlackBuild
+++ b/python/phply/phply.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=phply
VERSION=${VERSION:-1.2.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,16 +69,24 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py test
python setup.py install --root=$PKG
+# Find python version
+py2=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
+# Clean up to avoid collisions with other packages
+rm -r $PKG/usr/lib${LIBDIRSUFFIX}/python$py2/site-packages/tests
+
# Python 3 support.
# Be aware that the python3 tests downloads a
# newer version of nose in /tmp to succeed.
# This newer version of nose does not get installed on your system.
if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py test
python3 setup.py install --root=$PKG
+
+ # Find python3 version
+ py3=$(python3 -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
+ # Clean up to avoid collisions with other packages
+ rm -r $PKG/usr/lib${LIBDIRSUFFIX}/python$py3/site-packages/tests
fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/phply/phply.info b/python/phply/phply.info
index 5842ae3dd2..bdd0d73117 100644
--- a/python/phply/phply.info
+++ b/python/phply/phply.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/viraptor/phply/archive/1.2.5/phply-1.2.5.tar.gz"
MD5SUM="f6c0e4014fe70c6436984c07da836ae1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="nose ply"
+REQUIRES="ply"
MAINTAINER="Brenton Earl"
EMAIL="brent@exitstatusone.com"