summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Lionel Young <lionelyoung@gmail.com>2012-08-10 21:50:45 -0500
committer Robby Workman <rworkman@slackbuilds.org>2012-08-10 21:50:45 -0500
commit9149fe31478aaba296b32a75ca1813ee441a5210 (patch)
tree82e670abb583b6912d68c1e1551584d56e6c2c3c /python
parentcb3928b6eda11c9eea0f2fc9e7e08234e3f5beb1 (diff)
downloadslackbuilds-9149fe31478aaba296b32a75ca1813ee441a5210.tar.gz
slackbuilds-9149fe31478aaba296b32a75ca1813ee441a5210.tar.xz
python/pystatsd: Added (Graphite frontend)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pystatsd/README5
-rw-r--r--python/pystatsd/pystatsd.SlackBuild53
-rw-r--r--python/pystatsd/pystatsd.info10
-rw-r--r--python/pystatsd/slack-desc19
4 files changed, 87 insertions, 0 deletions
diff --git a/python/pystatsd/README b/python/pystatsd/README
new file mode 100644
index 0000000000..35a0d86cb3
--- /dev/null
+++ b/python/pystatsd/README
@@ -0,0 +1,5 @@
+pystatsd is a client and server implementation of
+Etsy's statsd server, a frontend/proxy for the
+Graphite stats collection and graphing server.
+
+This requires distribute and argparse.
diff --git a/python/pystatsd/pystatsd.SlackBuild b/python/pystatsd/pystatsd.SlackBuild
new file mode 100644
index 0000000000..888b03af95
--- /dev/null
+++ b/python/pystatsd/pystatsd.SlackBuild
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+# Slackware build script for pystatsd
+
+# Written by Lionel Young <lionelyoung@gmail.com>
+
+PRGNAM=pystatsd
+VERSION=${VERSION:-0.1.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pystatsd/pystatsd.info b/python/pystatsd/pystatsd.info
new file mode 100644
index 0000000000..551bd57d16
--- /dev/null
+++ b/python/pystatsd/pystatsd.info
@@ -0,0 +1,10 @@
+PRGNAM="pystatsd"
+VERSION="0.1.6"
+HOMEPAGE="http://github.com/sivy/py-statsd"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pystatsd/pystatsd-0.1.6.tar.gz"
+MD5SUM="db928fd295cdf3d3baf67029d0e9f419"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Lionel Young"
+EMAIL="lionelyoung@gmail.com"
+APPROVED="rworkman"
diff --git a/python/pystatsd/slack-desc b/python/pystatsd/slack-desc
new file mode 100644
index 0000000000..047cb278ec
--- /dev/null
+++ b/python/pystatsd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pystatsd: pystatsd (Graphite frontend)
+pystatsd:
+pystatsd: pystatsd is a client and server implementation of Etsy's statsd
+pystatsd: server, a front end/proxy for the Graphite stats collection and
+pystatsd: graphing server.
+pystatsd:
+pystatsd: Home: http://github.com/sivy/py-statsd
+pystatsd:
+pystatsd:
+pystatsd:
+pystatsd: