summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Alexander Verbovetsky <alik@ejik.org>2019-08-03 07:14:47 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-08-03 07:14:47 +0700
commit9c4901bc157618c8375c00bcb41fa1ac2a5dae6e (patch)
tree0371e32e5cda2d461064dcc4d25c685a832b191a /python
parent2fbb0b3e3fcf344cacf0518469de68a77b606dd5 (diff)
downloadslackbuilds-9c4901bc157618c8375c00bcb41fa1ac2a5dae6e.tar.gz
slackbuilds-9c4901bc157618c8375c00bcb41fa1ac2a5dae6e.tar.xz
python/python3-gmpy2: Added (multi-precision arithmetic).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-gmpy2/README8
-rw-r--r--python/python3-gmpy2/python3-gmpy2.SlackBuild72
-rw-r--r--python/python3-gmpy2/python3-gmpy2.info10
-rw-r--r--python/python3-gmpy2/slack-desc19
4 files changed, 109 insertions, 0 deletions
diff --git a/python/python3-gmpy2/README b/python/python3-gmpy2/README
new file mode 100644
index 0000000000..7ed7c73b52
--- /dev/null
+++ b/python/python3-gmpy2/README
@@ -0,0 +1,8 @@
+gmpy2 is an optimized, c-coded python extension module that supports
+fast multiple-precision arithmetic. gmpy2 is based on the original gmpy
+module. In addition to supporting gmp or mpir for multiple-precision
+integer and rational arithmetic, gmpy2 adds support for the mpfr
+(correctly rounded real floating-point arithmetic) and mpc (correctly
+rounded complex floating-point arithmetic) libraries.
+
+This is the python3 version of gmpy2.
diff --git a/python/python3-gmpy2/python3-gmpy2.SlackBuild b/python/python3-gmpy2/python3-gmpy2.SlackBuild
new file mode 100644
index 0000000000..5af9c0fbfd
--- /dev/null
+++ b/python/python3-gmpy2/python3-gmpy2.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for python3-gmpy2
+
+# Copyright 2019, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-gmpy2
+SRCNAM=gmpy2
+VERSION=${VERSION:-2.0.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+unzip $CWD/$SRCNAM-$VERSION.zip
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README docs $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-gmpy2/python3-gmpy2.info b/python/python3-gmpy2/python3-gmpy2.info
new file mode 100644
index 0000000000..6035012331
--- /dev/null
+++ b/python/python3-gmpy2/python3-gmpy2.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-gmpy2"
+VERSION="2.0.8"
+HOMEPAGE="https://github.com/aleaxit/gmpy"
+DOWNLOAD="https://pypi.python.org/packages/source/g/gmpy2/gmpy2-2.0.8.zip"
+MD5SUM="56d40bddcf8f22be0a36d60f764f3241"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/python/python3-gmpy2/slack-desc b/python/python3-gmpy2/slack-desc
new file mode 100644
index 0000000000..cf5f28e8e3
--- /dev/null
+++ b/python/python3-gmpy2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-gmpy2: python3-gmpy2 (multi-precision arithmetic for python 3)
+python3-gmpy2:
+python3-gmpy2: gmpy2 is an optimized, c-coded python extension module that supports
+python3-gmpy2: fast multiple-precision arithmetic. gmpy2 is based on the original
+python3-gmpy2: gmpy module. In addition to supporting gmp or mpir for
+python3-gmpy2: multiple-precision integer and rational arithmetic, gmpy2 adds support
+python3-gmpy2: for the mpfr (correctly rounded real floating-point arithmetic) and
+python3-gmpy2: mpc (correctly rounded complex floating-point arithmetic) libraries.
+python3-gmpy2:
+python3-gmpy2: Homepage: https://github.com/aleaxit/gmpy
+python3-gmpy2: